summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-05 22:04:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-06 22:36:34 +0000
commit6bd44129a76bdae1320f76035b23568a9c2b4e57 (patch)
tree1077d5185d0899f698d5183c92e72b419f924417 /meta/recipes-core
parent7977ff07d181d269bd52f98852d1076b268db614 (diff)
downloadopenembedded-core-6bd44129a76bdae1320f76035b23568a9c2b4e57.tar.gz
glib-2.0: show an error about --cross-file only when such file exists
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb
index a2fa5345b4..4176dbd207 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb
@@ -41,7 +41,8 @@ def find_meson_cross_files(d):
filename = os.path.normpath(os.path.join(path, "meson.cross.d", element))
sanitized_path = filename.replace(thisdir, "${THISDIR}")
if sanitized_path == filename:
- bb.error("Cannot add '%s' to --cross-file, because it's not relative to THISDIR '%s' and sstate signature would contain this full path" % (filename, thisdir))
+ if os.path.exists(filename):
+ bb.error("Cannot add '%s' to --cross-file, because it's not relative to THISDIR '%s' and sstate signature would contain this full path" % (filename, thisdir))
continue
files[filename.replace(thisdir, "${THISDIR}")] = os.path.exists(filename)