summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRobert Kovacsics <robert.kovacsics@carallon.com>2024-05-09 14:28:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-14 12:42:54 +0100
commitb175f9cdc3d87bef5c89cc337c2a7e2674732b29 (patch)
tree238a748d63204bb008311ed1e5b1924b18dd5245 /meta/recipes-core
parent69ead1f2d403e6a0e5365ce4e89288f846d3ef33 (diff)
downloadopenembedded-core-b175f9cdc3d87bef5c89cc337c2a7e2674732b29.tar.gz
sdk: Fix path length limit to match reserved size
There were two different interpreter lengths in use, make them match. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
index 7eebcaf11a..0fd01fdb64 100644
--- a/meta/recipes-core/meta/uninative-tarball.bb
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -58,6 +58,8 @@ fakeroot archive_sdk() {
DEST="./${SDK_ARCH}-${SDK_OS}"
mv sysroots/${SDK_SYS} $DEST
rm sysroots -rf
+ # There is a check in meta/files/toolchain-shar-extract.sh -- make sure to
+ # keep that check up to date if changing the `1024`
patchelf --set-interpreter ${@''.join('a' for n in range(1024))} $DEST/usr/bin/patchelf
mv $DEST/usr/bin/patchelf $DEST/usr/bin/patchelf-uninative
${SDK_ARCHIVE_CMD}