aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-09-03 02:50:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-14 08:28:54 +0100
commitdc3ac3d406bd6152eaa195e90b95bcdb0ac31121 (patch)
tree1f0066c9613b8922df2bc5294ea6e0d52db8088a /meta/recipes-core
parent05ac5627208c98007cd4c7aed9d76f179cd974a9 (diff)
downloadopenembedded-core-dc3ac3d406bd6152eaa195e90b95bcdb0ac31121.tar.gz
systemd: add ptest
Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd/run-ptest2
-rw-r--r--meta/recipes-core/systemd/systemd_206.bb16
2 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd/run-ptest b/meta/recipes-core/systemd/systemd/run-ptest
new file mode 100644
index 0000000000..0418bc977b
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/run-ptest
@@ -0,0 +1,2 @@
+make test/rules-test.sh.log
+make test/udev-test.pl.log
diff --git a/meta/recipes-core/systemd/systemd_206.bb b/meta/recipes-core/systemd/systemd_206.bb
index 2d0ce9b062..8d0a0657bb 100644
--- a/meta/recipes-core/systemd/systemd_206.bb
+++ b/meta/recipes-core/systemd/systemd_206.bb
@@ -15,7 +15,7 @@ DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SECTION = "base/shell"
-inherit gtk-doc useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd
+inherit gtk-doc useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest
SRC_URI = "http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz \
file://0001-use-CAP_MKNOD-ConditionCapability.patch \
@@ -25,6 +25,7 @@ SRC_URI = "http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz \
${UCLIBCPATCHES} \
file://00-create-volatile.conf \
file://init \
+ file://run-ptest \
"
SRC_URI[md5sum] = "89e36f2d3ba963020b72738549954cbc"
SRC_URI[sha256sum] = "4c993de071118ea1df7ffc4be26ef0b0d78354ef15b2743a2783d20edfcde9de"
@@ -114,6 +115,19 @@ do_install() {
fi
}
+do_install_ptest () {
+ install -d ${D}${PTEST_PATH}/test
+ install -d ${D}${libdir}/udev/rules.d
+ install ${B}/test/* ${D}${PTEST_PATH}/test
+ install -m 0755 ${B}/test-udev ${D}${PTEST_PATH}/
+ install -d ${D}${PTEST_PATH}/build-aux
+ cp -rf ${B}/rules ${D}${PTEST_PATH}/
+ cp ${B}/Makefile ${D}${PTEST_PATH}/
+ cp ${B}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
+ tar -C ${D}${PTEST_PATH}/test -xJf ${B}/test/sys.tar.xz
+ sed -i 's/"tree"/"ls"/' ${D}${PTEST_PATH}/test/udev-test.pl
+}
+
python populate_packages_prepend (){
systemdlibdir = d.getVar("rootlibdir", True)
do_split_packages(d, systemdlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True)