aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>2013-09-24 13:42:00 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-24 17:47:04 +0100
commitbec8a29fb27ccdada0839d0bdd67ae22179a94e8 (patch)
treef47bde05776a14ae6cf019d0997c8af115c78022 /meta/recipes-core
parentec7e738845f72888b0016340d7da636e5ec46a1b (diff)
downloadopenembedded-core-bec8a29fb27ccdada0839d0bdd67ae22179a94e8.tar.gz
systemd: fix ptest support
Currently do_install_ptest_base is failing because it cannot find 'test' directory in build dir, ${B}. 'test' directory is present in source dir, ${S}. Same is true for build-aux/test-driver and test/sys.tar.xz. Also this fixes: QA Issue: systemd: Files/directories were installed but not shipped /usr/lib/udev /usr/lib/udev/rules.d Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_206.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-core/systemd/systemd_206.bb b/meta/recipes-core/systemd/systemd_206.bb
index 8d0a0657bb..02be7935cd 100644
--- a/meta/recipes-core/systemd/systemd_206.bb
+++ b/meta/recipes-core/systemd/systemd_206.bb
@@ -117,14 +117,13 @@ do_install() {
do_install_ptest () {
install -d ${D}${PTEST_PATH}/test
- install -d ${D}${libdir}/udev/rules.d
- install ${B}/test/* ${D}${PTEST_PATH}/test
+ install ${S}/test/* ${D}${PTEST_PATH}/test
install -m 0755 ${B}/test-udev ${D}${PTEST_PATH}/
install -d ${D}${PTEST_PATH}/build-aux
cp -rf ${B}/rules ${D}${PTEST_PATH}/
cp ${B}/Makefile ${D}${PTEST_PATH}/
- cp ${B}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
- tar -C ${D}${PTEST_PATH}/test -xJf ${B}/test/sys.tar.xz
+ cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
+ tar -C ${D}${PTEST_PATH}/test -xJf ${S}/test/sys.tar.xz
sed -i 's/"tree"/"ls"/' ${D}${PTEST_PATH}/test/udev-test.pl
}