aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/udev
diff options
context:
space:
mode:
authorJohan Hovold <johan.hovold@lundinova.se>2012-12-18 18:46:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-19 17:50:02 +0000
commitf2ce905a92a2b5ff0a434249dc8468e3ee36aa63 (patch)
tree6771e3a5cc4a8e72ca0ac12e7a0f105b5c2ea7fc /meta/recipes-core/udev
parente1df16187f809c4a47480dc7ff6882f06624dedb (diff)
downloadopenembedded-core-f2ce905a92a2b5ff0a434249dc8468e3ee36aa63.tar.gz
udev: fix failed /dev/shm mount
Since commit commit fbec192f6bc4 ("udev: Ensure tmpfs are mounted and volatile/run exists") all tmpfs-entries in fstab are mounted before udev starts using mount -a. If /dev/shm is among those entries, that mount will fail as the mount point has not yet been created: Starting udev mount: mounting tmpfs on /dev/shm failed: No such file or directory udevd[474]: starting version 182 Fix by restoring the old way of mounting /dev and mounting the remaining tmpfs-entries only after /dev/shm has been created. Also make sure that any errors are supressed for these tmpfs-mounts. Should any mount point not yet be present, that mount will be retried later during the boot process. Signed-off-by: Johan Hovold <johan.hovold@lundinova.se> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/udev')
-rw-r--r--meta/recipes-core/udev/udev/init7
-rw-r--r--meta/recipes-core/udev/udev_182.bb2
2 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-core/udev/udev/init b/meta/recipes-core/udev/udev/init
index 74449feaaa..1934d11e49 100644
--- a/meta/recipes-core/udev/udev/init
+++ b/meta/recipes-core/udev/udev/init
@@ -37,10 +37,13 @@ export ACTION=add
echo "Starting udev"
# mount the tmpfs on /dev, if not already done
-mount -a -t tmpfs
-mkdir -p /var/volatile/run
+LANG=C awk '$2 == "/dev" && ($3 == "tmpfs" || $3 == "devtmpfs") { exit 1 }' /proc/mounts && {
+ mount -n -o mode=0755 -t tmpfs none "/dev"
+}
[ -e /dev/pts ] || mkdir -m 0755 /dev/pts
[ -e /dev/shm ] || mkdir -m 1777 /dev/shm
+mount -a -t tmpfs 2>/dev/null
+mkdir -p /var/volatile/run
# cache handling
if [ "$DEVCACHE" != "" ]; then
diff --git a/meta/recipes-core/udev/udev_182.bb b/meta/recipes-core/udev/udev_182.bb
index c41de9fef4..0ae9f8c6b6 100644
--- a/meta/recipes-core/udev/udev_182.bb
+++ b/meta/recipes-core/udev/udev_182.bb
@@ -1,6 +1,6 @@
include udev.inc
-PR = "r2"
+PR = "r3"
# module-init-tools from kmod_git will provide libkmod runtime
DEPENDS += "module-init-tools"