aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-13 14:34:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-13 16:19:20 +0100
commitcf9e6b299aaae23f459d1887e9acf721c0b3f9a4 (patch)
tree2278469902367972624ae72d8302812b56ae6cbb /meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
parent1b34b170620bb444bb2289950b6ed3ed2e909177 (diff)
downloadopenembedded-core-cf9e6b299aaae23f459d1887e9acf721c0b3f9a4.tar.gz
task-sdk-host: Add nativesdk to the task name so its clearer what the contents of the task represent
This is particularly important since the file doens't use BBCLASSEXTEND and PN is therefore misleading Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/tasks/task-sdk-host-nativesdk.bb')
-rw-r--r--meta/recipes-core/tasks/task-sdk-host-nativesdk.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb b/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
new file mode 100644
index 0000000000..5ec40b140c
--- /dev/null
+++ b/meta/recipes-core/tasks/task-sdk-host-nativesdk.bb
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd
+#
+
+DESCRIPTION = "Host packages for the standalone SDK or external toolchain"
+PR = "r10"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit nativesdk
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+ pkgconfig-nativesdk \
+ qemu-nativesdk \
+ qemu-helper-nativesdk \
+ pseudo-nativesdk \
+ unfs-server-nativesdk \
+ opkg-nativesdk \
+ libtool-nativesdk \
+ "
+
+RDEPENDS_${PN}_darwin8 = "\
+ odcctools-cross-canadian \
+ llvm-cross-canadian \
+ pkgconfig-nativesdk \
+ opkg-nativesdk \
+ libtool-nativesdk \
+ "