aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-06-11 18:00:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-11 18:05:07 +0100
commitc6c5c2285e1b6cb3598ccba08aee3dfd090e7129 (patch)
treee4b83539d8aff1856b298170b606a8e02f0b6433 /meta/recipes-core/systemd
parent694a15382fe9f3749ffdc0168a6dc2da8a29ae2d (diff)
downloadopenembedded-core-c6c5c2285e1b6cb3598ccba08aee3dfd090e7129.tar.gz
systemd: don't install quotaon.service twice
If the same file is installed twice there's a race which can lead to "make install" failing. Remove the redundant installation of quotaon.service to eliminate the race. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd/install-quotaon-once.patch32
-rw-r--r--meta/recipes-core/systemd/systemd_204.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/install-quotaon-once.patch b/meta/recipes-core/systemd/systemd/install-quotaon-once.patch
new file mode 100644
index 0000000000..10280dae43
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/install-quotaon-once.patch
@@ -0,0 +1,32 @@
+Upstream-Status: Submitted (https://bugs.freedesktop.org/show_bug.cgi?id=65659)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 44b7c4dc877984b5ea3f2c9fa09a93ee16dbe3b2 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Tue, 11 Jun 2013 17:16:37 +0100
+Subject: [PATCH] build-sys: don't install quotaon.service twice
+
+quotaon.service is already installed through dist_systemunit_DATA, so it doesn't
+need to be added to nodist_systemunit_DATA. Installing the same file twice
+results in a race condition where the install process can fail.
+---
+ Makefile.am | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 28ae7ed..197119e 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -3229,9 +3229,6 @@ endif
+ EXTRA_DIST += \
+ units/systemd-quotacheck.service.in
+
+-nodist_systemunit_DATA += \
+- units/quotaon.service
+-
+ # ------------------------------------------------------------------------------
+ if ENABLE_RANDOMSEED
+ rootlibexec_PROGRAMS += \
+--
+1.7.10.4
+
diff --git a/meta/recipes-core/systemd/systemd_204.bb b/meta/recipes-core/systemd/systemd_204.bb
index 5a63c7c14a..b8b1290940 100644
--- a/meta/recipes-core/systemd/systemd_204.bb
+++ b/meta/recipes-core/systemd/systemd_204.bb
@@ -22,6 +22,7 @@ SRC_URI = "http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz \
file://modprobe.rules \
${UCLIBCPATCHES} \
file://0001-utmp-turn-systemd-update-utmp-shutdown.service-into-.patch \
+ file://install-quotaon-once.patch \
file://00-create-volatile.conf \
file://init \
"