summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-08-30 15:52:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-01 10:12:49 +0100
commitc54f3847349173ed3a8e77a5c2732e1bbcddd540 (patch)
tree9f8ecc37ae5777fd89bf07635933b237c04a28e8 /meta/recipes-core/packagegroups
parentc991f9d603127d2b72a464974f0c5dfcc25727bf (diff)
downloadopenembedded-core-c54f3847349173ed3a8e77a5c2732e1bbcddd540.tar.gz
packagegroup-base.bb: add a configure option to set the wireless-daemon
Possible options would be wpa-supplicant or iwd. iwd is a wireless daemon written by intel and supported by all major network managers. It can be run in standalone mode and configured with 'iwctl' from the terminal, and with 'iwgtk' or 'iwdgui' from the gui. It can also work as a wpa_supplicant drop-in replacement for network-manager, connman or systemd-networkd. iwd makes heavy use of the kernel api, so it is not portable but does not need additional external libraries like openssl. The PACKAGECONFIG name for wpa-supplicant in the connman recipe is changed accordingly, so that it also works there when WIRELESS_DAEMON is set globally. Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-core/packagegroups')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index 7489ef61b0..d60e177471 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -267,11 +267,14 @@ RRECOMMENDS:packagegroup-base-ipsec = "\
# packagegroup-base-wifi contain everything needed to get WiFi working
# WEP/WPA connection needs to be supported out-of-box
#
+# Choose either 'wpa-supplicant' or 'iwd' as wireless-daemon
+WIRELESS_DAEMON ??= "wpa-supplicant"
SUMMARY:packagegroup-base-wifi = "WiFi support"
RDEPENDS:packagegroup-base-wifi = "\
iw \
wireless-regdb-static \
- wpa-supplicant"
+ ${WIRELESS_DAEMON} \
+"
RRECOMMENDS:packagegroup-base-wifi = "\
${@bb.utils.contains('COMBINED_FEATURES', 'usbhost', 'kernel-module-zd1211rw', '',d)} \