aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-31 10:45:58 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:52 -0700
commit592d6e602466628d10704835a7b07d3d713f58e1 (patch)
treef79c78d93cc303bd5c24d83215ec130cd89f3509 /meta/recipes-core/packagegroups
parentdbbcc0cb9d2cbc66027c800075b94eb9b7110a00 (diff)
downloadopenembedded-core-592d6e602466628d10704835a7b07d3d713f58e1.tar.gz
packagegroup-core-console: remove
This provides one package group, packagegroup-core-apps-console, which is usually brought in by adding "apps-console-core" to IMAGE_FEATURES. Aside from the naming inconsistencies, this is a group of mostly unrelated packages, none of which are actually "apps". Handling each one: * dbus: should mostly be brought in by package runtime dependencies * avahi-daemon: if you are using packagegroup-base (as all images that inherit from core-image do) this is brought in by having "zeroconf" in DISTRO_FEATURES. * portmap: not very useful by itself; should be brought in by selecting NFS server/client through other means. * psplash (or whatever SPLASH is set to): this has been changed to be an explicit item "splash" in IMAGE_FEATURES. Since this is a fairly fundamental feature, a piece of code has been added to automatically handle this for images still using apps-console-core (and show a warning). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/packagegroups')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-console.bb20
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-sdk.bb1
2 files changed, 0 insertions, 21 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-console.bb b/meta/recipes-core/packagegroups/packagegroup-core-console.bb
deleted file mode 100644
index 0c5e7f1e25..0000000000
--- a/meta/recipes-core/packagegroups/packagegroup-core-console.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2011 Intel Corporation
-#
-
-DESCRIPTION = "Tasks for core console applications"
-LICENSE = "MIT"
-PR = "r35"
-
-inherit packagegroup
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-SPLASH ?= "psplash"
-
-RDEPENDS_packagegroup-core-apps-console = "\
- avahi-daemon \
- dbus \
- portmap \
- ${SPLASH}"
-
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
index 8d7bbac3a5..e944ec5fe0 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
@@ -4,7 +4,6 @@
DESCRIPTION = "Software Development Tasks for OpenedHand Poky"
LICENSE = "MIT"
-DEPENDS = "packagegroup-core-console"
PR = "r8"
inherit packagegroup