summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ncurses
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-05-31 22:27:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-01 11:26:56 +0100
commitb6f4c130e5b2df458bf9d1b2d8edc8ac87fecf12 (patch)
tree525b090a8fdd5e4e61889c45ebb2d2c107467900 /meta/recipes-core/ncurses
parent83ad76453a86829c07052d506bc214923e696cf5 (diff)
downloadopenembedded-core-b6f4c130e5b2df458bf9d1b2d8edc8ac87fecf12.tar.gz
Revert "ncurses: fix incorrect UPSTREAM_CHECK_GITTAGREGEX"
This reverts commit 91227184b59df30222e45abf2edf13e4e65164a1. Instead of fixing incorrect regex, the commit actually broke the correct one. Before the reverted commit: alexander@alexander-box:~/development/poky$ devtool check-upgrade-status ncurses INFO: ncurses 6.1 6.1+20181013 Hongxu Jia <hongxu.jia@windriver.com> 7a97a7f937762ba342d5b2fd7cd090885a809835 After the reverted commit: alexander@alexander-box:~/development/poky$ devtool check-upgrade-status ncurses INFO: ncurses 6.1 UNKNOWN_BROKEN Hongxu Jia <hongxu.jia@windriver.com> The code in bitbake/lib/bb/fetch2/git.py actually splits each tag with '/' as separator and takes only the last part for some reason, so the "debian/" or "upstream/" prefixes are never a part of the string that is matched against regex: https://salsa.debian.org/debian/ncurses/tags Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ncurses')
-rw-r--r--meta/recipes-core/ncurses/ncurses_6.1+20181013.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb b/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb
index 928c47742c..ef6ca9879b 100644
--- a/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb
+++ b/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb
@@ -8,4 +8,4 @@ SRC_URI += "file://0001-tic-hang.patch \
SRCREV = "7a97a7f937762ba342d5b2fd7cd090885a809835"
S = "${WORKDIR}/git"
EXTRA_OECONF += "--with-abi-version=5 --cache-file=${B}/config.cache"
-UPSTREAM_CHECK_GITTAGREGEX = "upstream/(?P<pver>\d+(\.\d+)+(\+\d+)*)"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+(\+\d+)*)"