summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ncurses
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-05-12 16:16:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-12 14:17:51 +0100
commit50c872f402656e192d47b7a64e003f345227e55c (patch)
tree9bc4433aaf687125cc59a9c8e3fcb26674677ff5 /meta/recipes-core/ncurses
parentdb044235e72a1519a081c4f6541f7d7cfe70d49f (diff)
downloadopenembedded-core-50c872f402656e192d47b7a64e003f345227e55c.tar.gz
ncurses: fix incorrect UPSTREAM_CHECK_GITTAGREGEX
The upstream git tag has a `upstream/' prefix, such as: >>> import re >>> pattern = "upstream/(?P<pver>\d+(\.\d+)+(\+\d+)*)" >>> string = "upstream/6.1+20181013" >>> result = re.match(pattern, string) >>> result['pver'] '6.1+20181013' Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/ncurses')
-rw-r--r--meta/recipes-core/ncurses/ncurses_6.1+20181013.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb b/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb
index ef6ca9879b..928c47742c 100644
--- a/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb
+++ b/meta/recipes-core/ncurses/ncurses_6.1+20181013.bb
@@ -8,4 +8,4 @@ SRC_URI += "file://0001-tic-hang.patch \
SRCREV = "7a97a7f937762ba342d5b2fd7cd090885a809835"
S = "${WORKDIR}/git"
EXTRA_OECONF += "--with-abi-version=5 --cache-file=${B}/config.cache"
-UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+(\+\d+)*)"
+UPSTREAM_CHECK_GITTAGREGEX = "upstream/(?P<pver>\d+(\.\d+)+(\+\d+)*)"