aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-06-01 15:53:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-05 22:53:03 +0100
commit3c368f4c989bee68953b6d0fbf2adc44f97cc100 (patch)
tree4f4f2cc4f72a172707fe1c866ebee8e4bf30d257 /meta/recipes-core/meta
parentfb94ed0eb11b2efc1d814b80a2a7c99b29e746b3 (diff)
downloadopenembedded-core-3c368f4c989bee68953b6d0fbf2adc44f97cc100.tar.gz
external-sourcery-toolchain: forcibly create usr/lib
If the usr/lib directory doesn't exist, the toolchain can fail to even try to find crti.o in a completely different directory. This causes a failure for the case where baselib is lib64. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/external-sourcery-toolchain.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/meta/external-sourcery-toolchain.bb b/meta/recipes-core/meta/external-sourcery-toolchain.bb
index b67410b6d1..74c82ec978 100644
--- a/meta/recipes-core/meta/external-sourcery-toolchain.bb
+++ b/meta/recipes-core/meta/external-sourcery-toolchain.bb
@@ -24,7 +24,7 @@ PROVIDES += "\
virtual/linux-libc-headers \
"
PV = "${CSL_VER_MAIN}"
-PR = "r6"
+PR = "r7"
#SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/${CSL_TARGET_SYS}/arm-${PV}-${TARGET_PREFIX}i686-pc-linux-gnu.tar.bz2"
@@ -78,6 +78,10 @@ external_toolchain_sysroot_adjust() {
rm -f ${SYSROOT_DESTDIR}/$dest_sysroot
ln -s . ${SYSROOT_DESTDIR}/$dest_sysroot
fi
+
+ # If the usr/lib directory doesn't exist, the toolchain fails to even
+ # try to find crti.o in a completely different directory (usr/lib64)
+ install -d ${SYSROOT_DESTDIR}/usr/lib
}
PACKAGES =+ "libgcc libgcc-dev libstdc++ libstdc++-dev libstdc++-staticdev linux-libc-headers linux-libc-headers-dev gdbserver gdbserver-dbg"