summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.26.bb
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2018-01-02 16:13:48 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-04 12:56:04 +0000
commitd9583296be58f02912abc4fd19f576b3f89107ff (patch)
treea3328717cb612791d9f231895d1ce4473687d75a /meta/recipes-core/glibc/glibc_2.26.bb
parent58d31dddebbf7116e71bf45bd374a7a988f6016c (diff)
downloadopenembedded-core-d9583296be58f02912abc4fd19f576b3f89107ff.tar.gz
glibc: fix C++ compile failures related to 'assert'
* fixes "lambda-expression in unevaluated context" compile failures such as https://github.com/nlohmann/json/issues/705 * fixes "no match for 'operator==" compile failures such as https://bugzilla.redhat.com/show_bug.cgi?id=1482990 Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.26.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.26.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.26.bb b/meta/recipes-core/glibc/glibc_2.26.bb
index 135ec4fb16..7dd025ae68 100644
--- a/meta/recipes-core/glibc/glibc_2.26.bb
+++ b/meta/recipes-core/glibc/glibc_2.26.bb
@@ -43,6 +43,7 @@ SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
file://0026-assert-Suppress-pedantic-warning-caused-by-statement.patch \
file://0027-glibc-reset-dl-load-write-lock-after-forking.patch \
file://0028-Bug-4578-add-ld.so-lock-while-fork.patch \
+ file://0029-assert-Support-types-without-operator-int-BZ-21972.patch \
"
NATIVESDKFIXES ?= ""