aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-10-27 16:48:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:29 +0000
commit5193485a42dfb3396d0f12aaa7732c5db29d7338 (patch)
treed2fe40ae9bedc1b28057216571af4f99aa56fd4f /meta/recipes-core/glib-2.0
parent0c1c0a890f6e99608eda3d20a6b89027a2c72e96 (diff)
downloadopenembedded-core-5193485a42dfb3396d0f12aaa7732c5db29d7338.tar.gz
recipes-core: replace virtclass-native(sdk) with class-native(sdk)
The overrides virtclass-native and virtclass-nativesdk are deprecated, which should be replaced by class-native and class-nativesdk. [YOCTO #3297] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb6
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc6
2 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
index 10c0b615ed..22c6c7bef0 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
@@ -4,8 +4,8 @@ PR = "r6"
PE = "1"
DEPENDS += "libffi python-argparse-native zlib"
-DEPENDS_virtclass-native += "libffi-native python-argparse-native"
-DEPENDS_virtclass-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
+DEPENDS_class-native += "libffi-native python-argparse-native"
+DEPENDS_class-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
@@ -19,7 +19,7 @@ SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
SRC_URI[md5sum] = "bf84fefd9c1a5b5a7a38736f4ddd674a"
SRC_URI[sha256sum] = "a5d742a4fda22fb6975a8c0cfcd2499dd1c809b8afd4ef709bda4d11b167fae2"
-SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
+SRC_URI_append_class-native = " file://glib-gettextize-dir.patch"
BBCLASSEXTEND = "native nativesdk"
do_configure_prepend() {
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index 8b099f223e..6e2b5d2a74 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -14,8 +14,8 @@ BUGTRACKER = "http://bugzilla.gnome.org"
SECTION = "libs"
DEPENDS = "glib-2.0-native zip virtual/libiconv"
-DEPENDS_virtclass-native = "pkgconfig-native gettext-native"
-DEPENDS_virtclass-nativesdk = "nativesdk-libtool"
+DEPENDS_class-native = "pkgconfig-native gettext-native"
+DEPENDS_class-nativesdk = "nativesdk-libtool"
PACKAGES =+ "${PN}-utils ${PN}-bash-completion ${PN}-codegen"
LEAD_SONAME = "libglib-2.0.*"
@@ -28,7 +28,7 @@ S = "${WORKDIR}/glib-${PV}"
CORECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap"
EXTRA_OECONF = "--enable-included-printf=no ${CORECONF}"
-EXTRA_OECONF_virtclass-native = "${CORECONF}"
+EXTRA_OECONF_class-native = "${CORECONF}"
EXTRA_OECONF_linuxstdbase = "--enable-included-printf=no ${CORECONF}"
FILES_${PN} = "${libdir}/lib*${SOLIBS} ${datadir}/glib-2.0/schemas \