aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-04-16 16:36:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 22:52:39 +0100
commit13e6e316d751d0ea3107d5547f6bdd2b74919cad (patch)
tree04cc4fdaf633d3944d41640c2df0d6ce8f93d163 /meta/recipes-core/glib-2.0
parent19255032e7744fce5cbe466e4869ded378d3b4f5 (diff)
downloadopenembedded-core-13e6e316d751d0ea3107d5547f6bdd2b74919cad.tar.gz
glib-2.0: fix builds on fedora 17
Generally distros keep perl at /usr/bin/perl Fedora 17 also has /bin/perl this causes glib-2.0 build on such distros to put perl interpreter path in the perl scripts as /bin/perl But we set perl location for target as /usr/bin/perl This mismatch of perl path causes failure of rootfs image creation like this: | error: Failed dependencies: | /bin/perl is needed by libglib-2.0-utils-2.30.3-r0.ppc603e NOTE: package meta-toolchain-gmae-1.0-r7: task do_populate_sdk: Failed [YOCTO #2304] Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-core/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.30.3.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.30.3.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.30.3.bb
index 3b9da89f3f..f1f9217d1b 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.30.3.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.30.3.bb
@@ -1,6 +1,6 @@
require glib.inc
-PR = "r0"
+PR = "r1"
PE = "1"
DEPENDS += "libffi python-argparse-native zlib"
@@ -25,6 +25,10 @@ SRC_URI_append_libc-uclibc = " ${@['', 'file://no-iconv.patch']['${PN}' == '${BP
SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
BBCLASSEXTEND = "native nativesdk"
+PERLPATH = "${bindir}/env perl"
+PERLPATH_virtclass-native = "/usr/bin/env perl"
+PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
+
do_configure_prepend() {
# missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough, because it calls gtkdocize (not provided by gtk-doc-native)
sed -i '/^docs/d' ${S}/configure.ac
@@ -39,6 +43,12 @@ do_install_append() {
# and empty dirs
rmdir ${D}${libdir}/gio/modules/
rmdir ${D}${libdir}/gio/
+
+ # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+ # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+ if [ -f ${D}${bindir}/glib-mkenums ]; then
+ sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/glib-mkenums
+ fi
}
PACKAGES += "${PN}-codegen"