aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/feed-config
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 11:31:45 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 12:51:04 +0100
commitbc85abc5013d0c831cc3c3823df45536c293aaba (patch)
treeafa8b8cfd5649406eb4e9697082a6ad3da48ecdc /meta/recipes-core/feed-config
parent1d6156e37ef0f36cf5ce8eeaaf23560215c86833 (diff)
downloadopenembedded-core-bc85abc5013d0c831cc3c3823df45536c293aaba.tar.gz
opkg-config-base/poky-feed-config-opkg: Always use ALL_MULTILIB_PACKAGE_ARCHS to build arch list
We need consistent configuration files for opkg so we might as well always use the full list. This is equal to PACKAGE_ARCHS in the non-multilib case. This fixes various multilib failures with ipk multilibs. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/feed-config')
-rw-r--r--meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb b/meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb
index fc223c993b..14f1d4194a 100644
--- a/meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb
+++ b/meta/recipes-core/feed-config/poky-feed-config-opkg_1.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Poky example feed configuration"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r1"
+PR = "r2"
PACKAGE_ARCH = "${MACHINE_ARCH}"
INHIBIT_DEFAULT_DEPS = "1"
@@ -14,7 +14,7 @@ do_compile() {
archconf=${S}/${sysconfdir}/opkg/arch.conf
rm -f $archconf
- ipkgarchs="${PACKAGE_ARCHS}"
+ ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}"
priority=1
for arch in $ipkgarchs; do
echo "arch $arch $priority" >> $archconf