aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-02-28 13:56:26 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-02 12:53:38 +0000
commitf2804dc9a9ba666de85b4efb1fd005fa985f4f8a (patch)
tree6af0183a49d9d6c0706dc81ca1f771c5bafd8e46 /meta/recipes-core/eglibc
parent4067afcda78d17058f2aa8d7f82173d181e0aae4 (diff)
downloadopenembedded-core-f2804dc9a9ba666de85b4efb1fd005fa985f4f8a.tar.gz
eglibc: fix ldd RTLDLIST
The sed expression for retrieving the previous RTLDLIST from ldd script was also retrieving the double-quotes. Hence, we ended up with a RTLDLIST like below and ldd would fail: RTLDLIST=""/lib/ld-linux.so.2 /lib64/ld-linux-x86-64.so.2 /libx32/ld-linux-x32.so.2" /lib/ld-linux-x86-64.so.2" [YOCTO #3903] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.17.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.17.bb b/meta/recipes-core/eglibc/eglibc_2.17.bb
index fb49ac4535..6526978469 100644
--- a/meta/recipes-core/eglibc/eglibc_2.17.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.17.bb
@@ -144,7 +144,7 @@ do_compile () {
echo "Adjust ldd script"
if [ -n "${RTLDLIST}" ]
then
- prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST=\(.*\)$#\1#'`
+ prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
if [ "${prevrtld}" != "${RTLDLIST}" ]
then
sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"