aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-09-06 15:19:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 12:07:34 +0100
commit13e2ccf6f4e71d674583894750f70865ebe5e4d1 (patch)
tree82487f379512abef0e3ed668a6e95d0373e55584 /meta/recipes-core/eglibc
parent4282b86072fd5a916d0d12082d6ba575bce691f2 (diff)
downloadopenembedded-core-13e2ccf6f4e71d674583894750f70865ebe5e4d1.tar.gz
eglibc: Enable kconfig for option management
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/eglibc-initial.inc1
-rw-r--r--meta/recipes-core/eglibc/eglibc-options.inc4
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc4
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb3
4 files changed, 9 insertions, 3 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-initial.inc b/meta/recipes-core/eglibc/eglibc-initial.inc
index 3b99ac2854..f44db0c00e 100644
--- a/meta/recipes-core/eglibc/eglibc-initial.inc
+++ b/meta/recipes-core/eglibc/eglibc-initial.inc
@@ -19,6 +19,7 @@ do_configure () {
--prefix=/usr \
--without-cvs --disable-sanity-checks \
--with-headers=${STAGING_DIR_TARGET}${includedir} \
+ --with-kconfig=${STAGING_BINDIR_NATIVE} \
--enable-hacker-mode --enable-addons
}
diff --git a/meta/recipes-core/eglibc/eglibc-options.inc b/meta/recipes-core/eglibc/eglibc-options.inc
index 6009278577..8a8b364a6e 100644
--- a/meta/recipes-core/eglibc/eglibc-options.inc
+++ b/meta/recipes-core/eglibc/eglibc-options.inc
@@ -2,10 +2,10 @@ def eglibc_cfg(feature, features, tokens, cnf):
if type(tokens) == type(""):
tokens = [tokens]
if type(features) == type([]) and feature in features:
- cnf.extend([token + ' = y' for token in tokens])
+ cnf.extend([token + '=y' for token in tokens])
else:
for token in tokens:
- cnf.extend([token + ' = n'])
+ cnf.extend([token + '=n'])
if token == 'OPTION_EGLIBC_NSSWITCH':
cnf.extend(["OPTION_EGLIBC_NSSWITCH_FIXED_CONFIG = ${S}/nss/nsswitch.conf"])
cnf.extend(["OPTION_EGLIBC_NSSWITCH_FIXED_FUNCTIONS = ${S}/nss/fixed-nsswitch.functions"])
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index 02f3c7a959..29e303fafd 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -56,6 +56,10 @@ do_configure_prepend() {
echo '${OE_FEATURES}' > ${B}/option-groups.config
}
+do_configure_append() {
+ oe_runmake config
+}
+
GLIBC_ADDONS ?= "ports,nptl,libidn"
SDK_GLIBC_ADDONS ?= "ports,nptl,libidn"
GLIBC_ADDONS_virtclass-nativesdk = "${SDK_GLIBC_ADDONS}"
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 5a10387c1c..030b2351bd 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -2,7 +2,7 @@ require eglibc.inc
SRCREV = "20393"
-DEPENDS += "gperf-native"
+DEPENDS += "gperf-native kconfig-frontends-native"
PR = "r8"
PR_append = "+svnr${SRCPV}"
@@ -79,6 +79,7 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--with-headers=${STAGING_INCDIR} \
--without-selinux \
--enable-obsolete-rpc \
+ --with-kconfig=${STAGING_BINDIR_NATIVE} \
${GLIBC_EXTRA_OECONF}"
EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"