aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc-mtrace.inc
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2012-09-25 13:56:41 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-22 14:57:26 +0100
commit74b5f8943b2b29c7b3b62be7d81fb2b3a86b9584 (patch)
tree03cd109a102b3a6ffe13a079b585f8049b105c12 /meta/recipes-core/eglibc/eglibc-mtrace.inc
parent61131828c59178c923b3d5b5fcacf0dbcba275a5 (diff)
downloadopenembedded-core-74b5f8943b2b29c7b3b62be7d81fb2b3a86b9584.tar.gz
eglibc: Move perl- and bash-using scripts to separate recipes
This removes the dependency of eglibc.bb itself on perl and bash which, in turn, eliminates the need to build those two recipes if the scripts which need them are not going to be installed. Also provide dummy do_evacuate_scripts() for all variants of eglibc-initial otherwise the nativesdk and multilib variants might crash trying to copy a non-existent mtrace script. Signed-off-by: Phil Blundell <pb@pbcl.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc-mtrace.inc')
-rw-r--r--meta/recipes-core/eglibc/eglibc-mtrace.inc14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-mtrace.inc b/meta/recipes-core/eglibc/eglibc-mtrace.inc
new file mode 100644
index 0000000000..1ec93ac19b
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-mtrace.inc
@@ -0,0 +1,14 @@
+include eglibc-collateral.inc
+
+PR = "r1"
+SUMMARY = "mtrace utility provided by eglibc"
+DESCRIPTION = "mtrace utility provided by eglibc"
+RDEPENDS_${PN} = "perl"
+RPROVIDES_${PN} = "libc-mtrace"
+
+SRC = "${STAGING_INCDIR}/eglibc-scripts-internal-${MULTIMACH_TARGET_SYS}"
+
+do_install() {
+ install -d -m 0755 ${D}${bindir}
+ install -m 0755 ${SRC}/mtrace ${D}${bindir}/
+}