aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2013-07-22 03:45:41 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-31 06:56:27 +0100
commit25dc927009252151cc976b13c3f5bd19131cc4e8 (patch)
treeb8585e57e42ada65c5fe5a32f95bde0532a30bc0 /meta/recipes-core/dbus
parente01735756a76d27b724b9e7829f78e8a335c1f60 (diff)
downloadopenembedded-core-25dc927009252151cc976b13c3f5bd19131cc4e8.tar.gz
dbus: remove build host test in configure script
The dbus build tests the build host to detect what initscript environment it expects. Remove the test and set it to "redhat" unconditionally as the oe-core initscript has a redhat-style pid file path. Signed-off-by: Andy Ross <andy.ross@windriver.com Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Diffstat (limited to 'meta/recipes-core/dbus')
-rw-r--r--meta/recipes-core/dbus/dbus-1.6.10/os-test.patch35
-rw-r--r--meta/recipes-core/dbus/dbus.inc4
2 files changed, 38 insertions, 1 deletions
diff --git a/meta/recipes-core/dbus/dbus-1.6.10/os-test.patch b/meta/recipes-core/dbus/dbus-1.6.10/os-test.patch
new file mode 100644
index 0000000000..79554b1ee1
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-1.6.10/os-test.patch
@@ -0,0 +1,35 @@
+dbus: remove build host test in configure script
+
+The dbus build tests the build host to detect what initscript
+environment it expects. Remove the test and set it to "redhat"
+unconditionally as the oe-core initscript has a redhat-style pid file
+path.
+
+Signed-off-by: Andy Ross <andy.ross@windriver.com>
+Upstream-Status: innappropriate [embedded]
+
+diff -u a/configure.ac b/configure.ac
+--- a/configure.ac 2012-08-28 11:23:43.040609874 -0700
++++ b/configure.ac 2012-08-28 11:54:25.602913945 -0700
+@@ -1348,19 +1348,8 @@
+ AS_AC_EXPAND(EXPANDED_LIBEXECDIR, "$libexecdir")
+ AS_AC_EXPAND(EXPANDED_DATADIR, "$datadir")
+
+-#### Check our operating system
+-operating_system=unknown
+-if test -f /etc/redhat-release || test -f $EXPANDED_SYSCONFDIR/redhat-release ; then
+- operating_system=redhat
+-fi
+-
+-if test -f /etc/slackware-version || test -f $EXPANDED_SYSCONFDIR/slackware-version ; then
+- operating_system=slackware
+-fi
+-
+-if test -f /usr/bin/cygwin1.dll || test -f $EXPANDED_BINDIR/cygwin1.dll ; then
+- operating_system=cygwin
+-fi
++#### Build host test removed from upstream code, openembedded initscript is redhat-like:
++operating_system=redhat
+
+ #### Sort out init scripts
+
diff --git a/meta/recipes-core/dbus/dbus.inc b/meta/recipes-core/dbus/dbus.inc
index b07aefa3b5..580a93661a 100644
--- a/meta/recipes-core/dbus/dbus.inc
+++ b/meta/recipes-core/dbus/dbus.inc
@@ -16,7 +16,9 @@ INC_PR = "r6"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://tmpdir.patch; \
- file://dbus-1.init"
+ file://dbus-1.init \
+ file://os-test.patch \
+"
inherit useradd autotools pkgconfig gettext update-rc.d