aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-08-21 15:43:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-21 12:12:24 +0100
commitb30ef39cc26dd0b6ed08bd2b1a6394de6b540720 (patch)
treed9680a8646b1b47e5a2212564ff5c76e0b3fa2b1 /meta/recipes-core/coreutils
parent5d8ca498e09438bd91654fa8b8b2c970956d88e3 (diff)
downloadopenembedded-core-b30ef39cc26dd0b6ed08bd2b1a6394de6b540720.tar.gz
coreutils: fix to build with acl support
Fix the issue that coreutils was built without acl support: configure: WARNING: libacl development library was not found or not usable. configure: WARNING: GNU coreutils will be built without ACL support. which will cause ls and cp commands don't have the ACL related behaviors: ls -l: no plus sign(+) after the permission string for files that have ACL cp -p: can not preserves the ACLs. [YOCTO #2959] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch28
-rw-r--r--meta/recipes-core/coreutils/coreutils-8.14/coreutils-build-with-acl.patch28
-rw-r--r--meta/recipes-core/coreutils/coreutils_6.9.bb1
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.14.bb1
4 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch b/meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch
new file mode 100644
index 0000000000..8273d78eb3
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch
@@ -0,0 +1,28 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Fix the following issue so that coreutils can build with ACL:
+
+configure: WARNING: libacl development library was not found or not usable.
+configure: WARNING: GNU coreutils will be built without ACL support.
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ m4/acl.m4 | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/m4/acl.m4 b/m4/acl.m4
+index d6a448a..a9d4836 100644
+--- a/m4/acl.m4
++++ b/m4/acl.m4
+@@ -159,7 +159,7 @@ AC_DEFUN([gl_ACL_GET_FILE],
+ ]])],
+ [gl_cv_func_working_acl_get_file=yes],
+ [gl_cv_func_working_acl_get_file=no],
+- [gl_cv_func_working_acl_get_file=cross-compiling])])
++ [gl_cv_func_working_acl_get_file=yes])])
+
+ AS_IF([test $gl_cv_func_working_acl_get_file = yes], [$1], [$2])
+ ])
+--
+1.7.7
+
diff --git a/meta/recipes-core/coreutils/coreutils-8.14/coreutils-build-with-acl.patch b/meta/recipes-core/coreutils/coreutils-8.14/coreutils-build-with-acl.patch
new file mode 100644
index 0000000000..8273d78eb3
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils-8.14/coreutils-build-with-acl.patch
@@ -0,0 +1,28 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Fix the following issue so that coreutils can build with ACL:
+
+configure: WARNING: libacl development library was not found or not usable.
+configure: WARNING: GNU coreutils will be built without ACL support.
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ m4/acl.m4 | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/m4/acl.m4 b/m4/acl.m4
+index d6a448a..a9d4836 100644
+--- a/m4/acl.m4
++++ b/m4/acl.m4
+@@ -159,7 +159,7 @@ AC_DEFUN([gl_ACL_GET_FILE],
+ ]])],
+ [gl_cv_func_working_acl_get_file=yes],
+ [gl_cv_func_working_acl_get_file=no],
+- [gl_cv_func_working_acl_get_file=cross-compiling])])
++ [gl_cv_func_working_acl_get_file=yes])])
+
+ AS_IF([test $gl_cv_func_working_acl_get_file = yes], [$1], [$2])
+ ])
+--
+1.7.7
+
diff --git a/meta/recipes-core/coreutils/coreutils_6.9.bb b/meta/recipes-core/coreutils/coreutils_6.9.bb
index 5bfab163fb..20d8120930 100644
--- a/meta/recipes-core/coreutils/coreutils_6.9.bb
+++ b/meta/recipes-core/coreutils/coreutils_6.9.bb
@@ -24,6 +24,7 @@ SRC_URI_BASE = "${GNU_MIRROR}/coreutils/${BP}.tar.bz2 \
file://coreutils-fix-install.patch \
file://man-touch.patch \
file://coreutils_fix_for_automake-1.12.patch \
+ file://coreutils-build-with-acl.patch \
"
SRC_URI = "${SRC_URI_BASE} file://fix_for_manpage_building.patch"
diff --git a/meta/recipes-core/coreutils/coreutils_8.14.bb b/meta/recipes-core/coreutils/coreutils_8.14.bb
index 9a714a95f0..178bd674c6 100644
--- a/meta/recipes-core/coreutils/coreutils_8.14.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.14.bb
@@ -16,6 +16,7 @@ inherit autotools gettext
SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
file://remove-usr-local-lib-from-m4.patch \
file://remove-gets.patch \
+ file://coreutils-build-with-acl.patch \
"
SRC_URI[md5sum] = "bcb135ce553493a45aba01b39eb3920a"
SRC_URI[sha256sum] = "0d120817c19292edb19e92ae6b8eac9020e03d51e0af9cb116cf82b65d18b02d"