summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-08-30 15:52:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-01 10:12:49 +0100
commitc54f3847349173ed3a8e77a5c2732e1bbcddd540 (patch)
tree9f8ecc37ae5777fd89bf07635933b237c04a28e8 /meta/recipes-connectivity
parentc991f9d603127d2b72a464974f0c5dfcc25727bf (diff)
downloadopenembedded-core-c54f3847349173ed3a8e77a5c2732e1bbcddd540.tar.gz
packagegroup-base.bb: add a configure option to set the wireless-daemon
Possible options would be wpa-supplicant or iwd. iwd is a wireless daemon written by intel and supported by all major network managers. It can be run in standalone mode and configured with 'iwctl' from the terminal, and with 'iwgtk' or 'iwdgui' from the gui. It can also work as a wpa_supplicant drop-in replacement for network-manager, connman or systemd-networkd. iwd makes heavy use of the kernel api, so it is not portable but does not need additional external libraries like openssl. The PACKAGECONFIG name for wpa-supplicant in the connman recipe is changed accordingly, so that it also works there when WIRELESS_DAEMON is set globally. Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/connman/connman.inc8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index 9a518cdb2b..d7af94f792 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -29,9 +29,9 @@ EXTRA_OECONF += "\
--disable-polkit \
"
# For smooth operation it would be best to start only one wireless daemon at a time.
-# If wpa_supplicant is running, connman will use it preferentially.
-# Select either wpa_supplicant or iwd
-WIRELESS_DAEMON ??= "wpa_supplicant"
+# If wpa-supplicant is running, connman will use it preferentially.
+# Select either wpa-supplicant or iwd
+WIRELESS_DAEMON ??= "wpa-supplicant"
PACKAGECONFIG ??= "wispr iptables client\
${@bb.utils.filter('DISTRO_FEATURES', '3g systemd', d)} \
@@ -47,7 +47,7 @@ PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_system_unitdir}/ --wit
PACKAGECONFIG[wifi] = "--enable-wifi, --disable-wifi"
PACKAGECONFIG[bluez] = "--enable-bluetooth, --disable-bluetooth, bluez5, bluez5"
PACKAGECONFIG[3g] = "--enable-ofono, --disable-ofono, ofono, ofono"
-PACKAGECONFIG[wpa_supplicant] = ",,wpa-supplicant,wpa-supplicant"
+PACKAGECONFIG[wpa-supplicant] = ",,wpa-supplicant,wpa-supplicant"
PACKAGECONFIG[iwd] = "--enable-iwd,--disable-iwd,,iwd"
PACKAGECONFIG[tist] = "--enable-tist,--disable-tist,"
PACKAGECONFIG[openvpn] = "--enable-openvpn --with-openvpn=${sbindir}/openvpn,--disable-openvpn,,openvpn"