aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-02-17 15:16:02 +0800
committerSaul Wold <sgw@linux.intel.com>2011-02-17 17:25:22 -0800
commit3810796ee371c8b1548f5ba75ff55299f37d0254 (patch)
tree5961b4a798541fa983cc0bed07273c52a36abed4 /meta/recipes-connectivity/openssl
parentc35d91062f557d46625eb471cf1edf2c4d95b1b8 (diff)
downloadopenembedded-core-3810796ee371c8b1548f5ba75ff55299f37d0254.tar.gz
openssl: fix parallel make
Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl')
-rw-r--r--meta/recipes-connectivity/openssl/openssl-0.9.8p/parallel-make-fix.patch18
-rw-r--r--meta/recipes-connectivity/openssl/openssl.inc6
-rw-r--r--meta/recipes-connectivity/openssl/openssl_0.9.8p.bb2
3 files changed, 22 insertions, 4 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-0.9.8p/parallel-make-fix.patch b/meta/recipes-connectivity/openssl/openssl-0.9.8p/parallel-make-fix.patch
new file mode 100644
index 0000000000..60fab9d4a9
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-0.9.8p/parallel-make-fix.patch
@@ -0,0 +1,18 @@
+fix the parallel build regarding shared libraries.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/Makefile.org b/Makefile.org
+index 2fb0309..8bec3d0 100644
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -352,6 +352,9 @@ all_testapps: build_libs build_testapps
+ build_testapps:
+ @dir=crypto; target=testapps; $(BUILD_ONE_CMD)
+
++libcrypto.a: build_crypto
++libssl.a: build_ssl
++
+ build_shared: $(SHARED_LIBS)
+ libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS)
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
diff --git a/meta/recipes-connectivity/openssl/openssl.inc b/meta/recipes-connectivity/openssl/openssl.inc
index f054c26ca6..68b3d7bd0a 100644
--- a/meta/recipes-connectivity/openssl/openssl.inc
+++ b/meta/recipes-connectivity/openssl/openssl.inc
@@ -10,7 +10,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=83d26c69f6f0172ee7f795790424b453"
DEPENDS = "perl-native"
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz"
+SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
+ file://parallel-make-fix.patch \
+ "
S = "${WORKDIR}/openssl-${PV}"
AR_append = " r"
@@ -29,8 +31,6 @@ export DIRS = "crypto ssl apps"
export EX_LIBS = "-lgcc -ldl"
export AS = "${CC} -c"
-PARALLEL_MAKE = ""
-
inherit pkgconfig siteinfo
PACKAGES =+ "libcrypto libssl"
diff --git a/meta/recipes-connectivity/openssl/openssl_0.9.8p.bb b/meta/recipes-connectivity/openssl/openssl_0.9.8p.bb
index 283b82add0..f42b3cbf6b 100644
--- a/meta/recipes-connectivity/openssl/openssl_0.9.8p.bb
+++ b/meta/recipes-connectivity/openssl/openssl_0.9.8p.bb
@@ -1,6 +1,6 @@
require openssl.inc
-PR = "r2"
+PR = "r3"
SRC_URI += "file://debian/ca.patch \
file://debian/config-hurd.patch;apply=no \
file://debian/debian-targets.patch \