aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssh
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-03-10 16:06:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-10 18:34:06 -0800
commit9f4747a1e7e04e0b08b7b402bd8dd7cf8ccd0166 (patch)
treecad4b68d3fab24af76bc5052f05aed6d3d876166 /meta/recipes-connectivity/openssh
parent285fbd8a206eee061e27f37430499fcbe1e7284d (diff)
downloadopenembedded-core-9f4747a1e7e04e0b08b7b402bd8dd7cf8ccd0166.tar.gz
openssh: allow the openssh meta package to be empty
This allows the openssh meta-package to be used in the poky-ssh task. Otherwise there will be no package named openssh to install during image creation. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssh')
-rw-r--r--meta/recipes-connectivity/openssh/openssh_5.6p1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_5.6p1.bb b/meta/recipes-connectivity/openssh/openssh_5.6p1.bb
index be9ae09735..d93a773f7f 100644
--- a/meta/recipes-connectivity/openssh/openssh_5.6p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_5.6p1.bb
@@ -7,7 +7,7 @@ SECTION = "console/network"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENCE;md5=7ae09218173be1643c998a4b71027f9b"
-PR = "r0"
+PR = "r1"
DEPENDS = "zlib openssl"
DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
@@ -67,6 +67,8 @@ do_install_append () {
rmdir ${D}/var/run/sshd ${D}/var/run ${D}/var
}
+ALLOW_EMPTY_${PN} = "1"
+
PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
FILES_${PN}-scp = "${bindir}/scp.${PN}"
FILES_${PN}-ssh = "${bindir}/ssh.${PN} ${sysconfdir}/ssh/ssh_config"