aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssh
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-09-15 16:10:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-09-15 16:13:55 +0200
commit998e3acf0d38007fde10f47f98b71192685e19b9 (patch)
treee5e8d331a4eb9ad8a7fa2070b0d908568917f23f /meta/recipes-connectivity/openssh
parente876a44fa8ed0aa2e09084c1e7ddfc876c3f981b (diff)
downloadopenembedded-core-998e3acf0d38007fde10f47f98b71192685e19b9.tar.gz
openssh: update init script to create ECDSA keys if needed
* Starting with openssh-5.8p1, the server will default to a newer key algorithm (ECDSA). Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-connectivity/openssh')
-rw-r--r--meta/recipes-connectivity/openssh/openssh-5.8p2/init4
-rw-r--r--meta/recipes-connectivity/openssh/openssh_5.8p2.bb2
2 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh-5.8p2/init b/meta/recipes-connectivity/openssh/openssh-5.8p2/init
index b16cbd61a6..055dd22e1b 100644
--- a/meta/recipes-connectivity/openssh/openssh-5.8p2/init
+++ b/meta/recipes-connectivity/openssh/openssh-5.8p2/init
@@ -36,6 +36,10 @@ check_keys() {
echo " generating ssh RSA key..."
ssh-keygen -q -f /etc/ssh/ssh_host_rsa_key -N '' -t rsa
fi
+ if [ ! -f /etc/ssh/ssh_host_ecdsa_key ]; then
+ echo " generating ssh ECDSA key..."
+ ssh-keygen -q -f /etc/ssh/ssh_host_ecdsa_key -N '' -t ecdsa
+ fi
if [ ! -f /etc/ssh/ssh_host_dsa_key ]; then
echo " generating ssh DSA key..."
ssh-keygen -q -f /etc/ssh/ssh_host_dsa_key -N '' -t dsa
diff --git a/meta/recipes-connectivity/openssh/openssh_5.8p2.bb b/meta/recipes-connectivity/openssh/openssh_5.8p2.bb
index 89b011d6f8..030a83b91f 100644
--- a/meta/recipes-connectivity/openssh/openssh_5.8p2.bb
+++ b/meta/recipes-connectivity/openssh/openssh_5.8p2.bb
@@ -7,7 +7,7 @@ SECTION = "console/network"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENCE;md5=bae9a689be41581503bcf95d8fb42c4e"
-PR = "r1"
+PR = "r2"
DEPENDS = "zlib openssl"
DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"