aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/dhcp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-21 14:28:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-21 17:04:56 +0000
commita3238c1e1317c4fd5526c8854403a2160cb51bb0 (patch)
tree5ff22586cadf1ab97dbc48f74d9ac30398ee1a63 /meta/recipes-connectivity/dhcp
parent15d7fe81bf3c52a14bfdd6a8a854836c8571e14f (diff)
downloadopenembedded-core-a3238c1e1317c4fd5526c8854403a2160cb51bb0.tar.gz
dhcp: Fix case where ${B} != ${S}
Add patch to allow out of tree builds to work. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/dhcp')
-rw-r--r--meta/recipes-connectivity/dhcp/dhcp-4.2.5/fixsepbuild.patch90
-rw-r--r--meta/recipes-connectivity/dhcp/dhcp_4.2.5.bb1
2 files changed, 91 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/dhcp/dhcp-4.2.5/fixsepbuild.patch b/meta/recipes-connectivity/dhcp/dhcp-4.2.5/fixsepbuild.patch
new file mode 100644
index 0000000000..e686afd2d2
--- /dev/null
+++ b/meta/recipes-connectivity/dhcp/dhcp-4.2.5/fixsepbuild.patch
@@ -0,0 +1,90 @@
+Fix out of tree builds
+
+Upstream-Status: Pending
+
+RP 2013/03/21
+
+Index: dhcp-4.2.5/common/Makefile.am
+===================================================================
+--- dhcp-4.2.5.orig/common/Makefile.am 2013-03-21 12:54:11.345063519 +0000
++++ dhcp-4.2.5/common/Makefile.am 2013-03-21 12:54:11.805063510 +0000
+@@ -1,4 +1,4 @@
+-AM_CPPFLAGS = -I.. -DLOCALSTATEDIR='"@localstatedir@"'
++AM_CPPFLAGS = -I$(top_srcdir)/includes -I$(top_srcdir) -DLOCALSTATEDIR='"@localstatedir@"'
+ AM_CFLAGS = $(LDAP_CFLAGS)
+
+ noinst_LIBRARIES = libdhcp.a
+Index: dhcp-4.2.5/dst/Makefile.am
+===================================================================
+--- dhcp-4.2.5.orig/dst/Makefile.am 2013-03-21 12:54:11.345063519 +0000
++++ dhcp-4.2.5/dst/Makefile.am 2013-03-21 12:54:11.805063510 +0000
+@@ -1,4 +1,4 @@
+-AM_CPPFLAGS = -DMINIRES_LIB -DHMAC_MD5
++AM_CPPFLAGS = -DMINIRES_LIB -DHMAC_MD5 -I$(top_srcdir)/includes
+
+ lib_LIBRARIES = libdst.a
+
+Index: dhcp-4.2.5/omapip/Makefile.am
+===================================================================
+--- dhcp-4.2.5.orig/omapip/Makefile.am 2013-03-21 12:54:11.677063511 +0000
++++ dhcp-4.2.5/omapip/Makefile.am 2013-03-21 12:54:11.809063510 +0000
+@@ -1,3 +1,5 @@
++AM_CPPFLAGS = -I$(top_srcdir)/includes
++
+ lib_LIBRARIES = libomapi.a
+ noinst_PROGRAMS = svtest
+
+Index: dhcp-4.2.5/client/Makefile.am
+===================================================================
+--- dhcp-4.2.5.orig/client/Makefile.am 2013-03-21 12:54:11.677063511 +0000
++++ dhcp-4.2.5/client/Makefile.am 2013-03-21 12:54:11.809063510 +0000
+@@ -1,3 +1,5 @@
++AM_CPPFLAGS = -I$(top_srcdir)/includes
++
+ dist_sysconf_DATA = dhclient.conf.example
+ sbin_PROGRAMS = dhclient
+ dhclient_SOURCES = clparse.c dhclient.c dhc6.c \
+@@ -11,8 +13,8 @@
+
+ dhclient.o: dhclient.c
+ $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):/sbin:/bin:/usr/sbin:/usr/bin"' \
+- -DLOCALSTATEDIR='"$(localstatedir)"' -c dhclient.c
++ -DLOCALSTATEDIR='"$(localstatedir)"' -c $(srcdir)/dhclient.c
+
+ dhc6.o: dhc6.c
+ $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):/sbin:/bin:/usr/sbin:/usr/bin"' \
+- -DLOCALSTATEDIR='"$(localstatedir)"' -c dhc6.c
++ -DLOCALSTATEDIR='"$(localstatedir)"' -c $(srcdir)/dhc6.c
+Index: dhcp-4.2.5/dhcpctl/Makefile.am
+===================================================================
+--- dhcp-4.2.5.orig/dhcpctl/Makefile.am 2013-03-21 12:54:11.677063511 +0000
++++ dhcp-4.2.5/dhcpctl/Makefile.am 2013-03-21 12:54:11.809063510 +0000
+@@ -1,3 +1,5 @@
++AM_CPPFLAGS = -I$(top_srcdir)/includes -I$(top_srcdir)
++
+ bin_PROGRAMS = omshell
+ lib_LIBRARIES = libdhcpctl.a
+ noinst_PROGRAMS = cltest
+Index: dhcp-4.2.5/relay/Makefile.am
+===================================================================
+--- dhcp-4.2.5.orig/relay/Makefile.am 2013-03-21 12:54:11.677063511 +0000
++++ dhcp-4.2.5/relay/Makefile.am 2013-03-21 12:54:11.809063510 +0000
+@@ -1,4 +1,4 @@
+-AM_CPPFLAGS = -DLOCALSTATEDIR='"@localstatedir@"'
++AM_CPPFLAGS = -DLOCALSTATEDIR='"@localstatedir@"' -I$(top_srcdir)/includes
+
+ sbin_PROGRAMS = dhcrelay
+ dhcrelay_SOURCES = dhcrelay.c
+Index: dhcp-4.2.5/server/Makefile.am
+===================================================================
+--- dhcp-4.2.5.orig/server/Makefile.am 2013-03-21 12:54:11.677063511 +0000
++++ dhcp-4.2.5/server/Makefile.am 2013-03-21 12:55:01.509062081 +0000
+@@ -4,7 +4,7 @@
+ # production code. Sadly, we are not there yet.
+ SUBDIRS = . tests
+
+-AM_CPPFLAGS = -I.. -DLOCALSTATEDIR='"@localstatedir@"'
++AM_CPPFLAGS = -I$(top_srcdir) -DLOCALSTATEDIR='"@localstatedir@"' -I$(top_srcdir)/includes
+
+ dist_sysconf_DATA = dhcpd.conf.example
+ sbin_PROGRAMS = dhcpd
diff --git a/meta/recipes-connectivity/dhcp/dhcp_4.2.5.bb b/meta/recipes-connectivity/dhcp/dhcp_4.2.5.bb
index 0f247ae055..3ec9f3b083 100644
--- a/meta/recipes-connectivity/dhcp/dhcp_4.2.5.bb
+++ b/meta/recipes-connectivity/dhcp/dhcp_4.2.5.bb
@@ -6,6 +6,7 @@ SRC_URI += "file://fixincludes.patch \
file://dhcp-3.0.3-dhclient-dbus.patch;striplevel=0 \
file://fix-external-bind.patch \
file://link-with-lcrypto.patch \
+ file://fixsepbuild.patch \
"
SRC_URI[md5sum] = "6489e919ac093d17249270ee9be1020e"