aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/connman
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2013-03-22 10:11:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-22 16:22:05 +0000
commit858ad53aee9ef5848c09d76c0e6bf464bc31d30e (patch)
tree73feb06066e00a72046e5d3af7ee3d5f54a905b4 /meta/recipes-connectivity/connman
parentbc830ab3f6e9704c830e934c6f39c85ef11f867d (diff)
downloadopenembedded-core-858ad53aee9ef5848c09d76c0e6bf464bc31d30e.tar.gz
connman-conf: Move the setup script into /usr/lib/connman
The /etc/connman is not suitable for the setup script. There are other connman related scripts in /usr/lib/connman so moving the wired setup script there. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/connman')
-rw-r--r--meta/recipes-connectivity/connman/connman-conf.bb8
-rw-r--r--meta/recipes-connectivity/connman/connman/connman4
2 files changed, 7 insertions, 5 deletions
diff --git a/meta/recipes-connectivity/connman/connman-conf.bb b/meta/recipes-connectivity/connman/connman-conf.bb
index 7b999533f1..6ecfbfbe86 100644
--- a/meta/recipes-connectivity/connman/connman-conf.bb
+++ b/meta/recipes-connectivity/connman/connman-conf.bb
@@ -6,16 +6,18 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=80
SRC_URI_append_qemuall = "file://wired.config \
file://wired-setup \
"
-PR = "r1"
+PR = "r2"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+FILES_${PN} = "${localstatedir}/* ${libdir}/*"
+
do_install() {
#Configure Wired network interface in case of qemu* machines
if test -e ${WORKDIR}/wired.config && test -e ${WORKDIR}/wired-setup; then
install -d ${D}${localstatedir}/lib/connman
install -m 0644 ${WORKDIR}/wired.config ${D}${localstatedir}/lib/connman
- install -d ${D}${sysconfdir}/connman
- install -m 0755 ${WORKDIR}/wired-setup ${D}${sysconfdir}/connman
+ install -d ${D}${libdir}/connman
+ install -m 0755 ${WORKDIR}/wired-setup ${D}${libdir}/connman
fi
}
diff --git a/meta/recipes-connectivity/connman/connman/connman b/meta/recipes-connectivity/connman/connman/connman
index ffd7fac547..a111f609dc 100644
--- a/meta/recipes-connectivity/connman/connman/connman
+++ b/meta/recipes-connectivity/connman/connman/connman
@@ -32,8 +32,8 @@ do_start() {
ethn=`ifconfig | grep eth | sed -e "s/\(eth[0-9]\)\(.*\)/\1/"`
EXTRA_PARAM="-I $ethn"
fi
- if [ -f /etc/connman/wired-setup ] ; then
- . /etc/connman/wired-setup
+ if [ -f /usr/lib/connman/wired-setup ] ; then
+ . /usr/lib/connman/wired-setup
fi
$DAEMON $EXTRA_PARAM
}