aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/connman
diff options
context:
space:
mode:
authorRadu Moisan <radu.moisan@intel.com>2013-02-08 22:43:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-11 14:44:32 +0000
commit352b3e3663fc4ccab2d8240176f4b085db726e82 (patch)
treec2dbc0a65c6f75997c65b619d61912a3522b9ec9 /meta/recipes-connectivity/connman
parent0273a22fec3c9360df2510b759c5bf9af610551f (diff)
downloadopenembedded-core-352b3e3663fc4ccab2d8240176f4b085db726e82.tar.gz
connman: Enabling with systemd
Signed-off-by: Radu Moisan <radu.moisan@intel.com> Signed-off-by: Sander van Grieken <sander@outrightsolutions.nl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/connman')
-rw-r--r--meta/recipes-connectivity/connman/connman.inc11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index 5c9aa6de06..b61e2afd26 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -40,11 +40,14 @@ EXTRA_OECONF += "\
--disable-polkit \
--disable-client \
--enable-fake \
+ ${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdunitdir=${systemd_unitdir}/system/', '', d)} \
"
INITSCRIPT_NAME = "connman"
INITSCRIPT_PARAMS = "start 05 5 2 3 . stop 22 0 1 6 ."
+SYSTEMD_SERVICE_${PN} = "connman.service"
+
# IMPORTANT: because xuser is shared with rootless X, please make sure the
# USERADD_PARAM is in sync with the one in xserver-nodm-init.bb
USERADD_PACKAGES = "${PN}"
@@ -52,7 +55,7 @@ USERADD_PARAM_${PN} = "--create-home \
--groups video,tty,audio \
--user-group xuser"
-inherit autotools gtk-doc pkgconfig update-rc.d useradd
+inherit autotools gtk-doc pkgconfig systemd update-rc.d useradd
# This allows *everyone* to access ConnMan over DBus, without any access
# control. Really the at_console flag should work, which would mean that
@@ -62,8 +65,10 @@ do_compile_append() {
}
do_install_append() {
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
+ if ${@base_contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
+ fi
install -d ${D}${bindir}
install -m 0755 ${S}/tools/*-test ${D}${bindir}