aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-18 00:03:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-31 12:56:38 +0100
commit26e5e5feb695864b11e47e24017e254c28f14494 (patch)
tree754537dc0577fdcb6cf753bfbd926aeb74183789 /meta/recipes-connectivity/bluez
parent5c3f39c56d1a7402c1f1f3b6db1f2764fcc8f190 (diff)
downloadopenembedded-core-26e5e5feb695864b11e47e24017e254c28f14494.tar.gz
Improve handling of 'all' architecture recipes and their interaction with sstate
The existing PACKAGE_ARCH = "all" mechanism of sharing packages is problematic with sstate since there are a variety of variables which have target specific values and the sstate package therefore correctly changes signature depending on the MACHINE setting. This patch creates a new "allarch" class which sets: PACKAGE_ARCH = "all" (as per the existing convention) INHIBIT_DEFAULT_DEPS = "1" (since its not target specific and therefore can't depend on the cross compiler or target libc) TARGET_ARCH = "all" TARGET_OS = "linux" TARGET_CC_ARCH = "none" (since these variables shouldn't change between the different packages and target compiler flags shouldn't be getting used) PACKAGE_EXTRA_ARCHS = "" (since we shouldn't be depending on any architecture specific package architectures) Not all PACKAGE_ARCH = "all" recipes can use this class since some run configure checks on the compiler. This means they have target specific components and therefore the "all" classification is incorrect. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bluez')
-rw-r--r--meta/recipes-connectivity/bluez/bluez-dtl1-workaround_1.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez-dtl1-workaround_1.0.bb b/meta/recipes-connectivity/bluez/bluez-dtl1-workaround_1.0.bb
index 4dfdcb247a..b6b3d7dcfd 100644
--- a/meta/recipes-connectivity/bluez/bluez-dtl1-workaround_1.0.bb
+++ b/meta/recipes-connectivity/bluez/bluez-dtl1-workaround_1.0.bb
@@ -3,11 +3,13 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
SECTION = "console"
PRIORITY = "optional"
-PR = "r2"
+PR = "r3"
SRC_URI = "file://02dtl1_cs.sh \
file://COPYING.patch"
+inherit allarch
+
do_install() {
install -d ${D}${sysconfdir}/apm/event.d/
install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
@@ -15,5 +17,3 @@ do_install() {
#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
FILES_${PN} += "${sysconfdir}/apm/"
-
-PACKAGE_ARCH = "all"