aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-07-20 09:24:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-27 14:07:22 +0100
commit06b5d57e89f2dd20fb3f4cb9fd362e2d428f493d (patch)
tree5caeac09a8ef3a5177b5be34f2625e47ed99689c /meta/recipes-connectivity/bluez
parent695598415b4e9e17def7f04332bdbc0d24cc1efc (diff)
downloadopenembedded-core-06b5d57e89f2dd20fb3f4cb9fd362e2d428f493d.tar.gz
bluez4: use PACKAGECONFIG to control 'pie'
This lets us control whether we build position independent executables. As, as far as I know no distros are adding a 'pie' distro feature, the effect of this commit for most will be to disable pie in bluez4. I think this is best to ensure consistent behavior among the recipes with regard to this. This also sidesteps a build failure I've seen with bluez4 failing due to libudev.a not having been built fPIC. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity/bluez')
-rw-r--r--meta/recipes-connectivity/bluez/bluez4.inc6
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.101.bb2
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4.inc b/meta/recipes-connectivity/bluez/bluez4.inc
index 6dc06f46b9..6ddd58df0c 100644
--- a/meta/recipes-connectivity/bluez/bluez4.inc
+++ b/meta/recipes-connectivity/bluez/bluez4.inc
@@ -10,8 +10,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
DEPENDS = "udev libusb dbus-glib glib-2.0 libcheck"
RDEPENDS_${PN}-dev = "bluez-hcidump"
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
+PACKAGECONFIG ??= "\
+ ${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}\
+ ${@base_contains('DISTRO_FEATURES', 'pie', 'pie', '', d)}\
+"
PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
+PACKAGECONFIG[pie] = "--enable-pie,--disable-pie,"
ASNEEDED = ""
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.101.bb b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
index 4a360b693e..e26d4eac8b 100644
--- a/meta/recipes-connectivity/bluez/bluez4_4.101.bb
+++ b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
@@ -1,6 +1,6 @@
require bluez4.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://bluetooth.conf \
file://sbc_mmx.patch"