summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez5/bluez5.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-10 13:29:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-10 13:29:57 +0000
commit3351c0ba4b54b513f95717cdfb54a87a8b0a1a94 (patch)
treea5e60428fe4e6fd694b3b2fbbfe3b8d2746fddea /meta/recipes-connectivity/bluez5/bluez5.inc
parent42719edc86ac2013280a34f1c58ca83726cec04a (diff)
downloadopenembedded-core-3351c0ba4b54b513f95717cdfb54a87a8b0a1a94.tar.gz
Revert "bluez: update 5.50 -> 5.52"
This reverts commit dad8cd50bcc4203a65d153dc2445502c1e728975. It is causing performance problems in ptest, taking hours (~18) to parse the ptest runner logs. Log output increased from ~4MB to ~65MB. Revert until we can deal with the performance issue.
Diffstat (limited to 'meta/recipes-connectivity/bluez5/bluez5.inc')
-rw-r--r--meta/recipes-connectivity/bluez5/bluez5.inc22
1 files changed, 14 insertions, 8 deletions
diff --git a/meta/recipes-connectivity/bluez5/bluez5.inc b/meta/recipes-connectivity/bluez5/bluez5.inc
index 150d909d73..484509350b 100644
--- a/meta/recipes-connectivity/bluez5/bluez5.inc
+++ b/meta/recipes-connectivity/bluez5/bluez5.inc
@@ -46,13 +46,20 @@ PACKAGECONFIG[mesh] = "--enable-mesh,--disable-mesh, json-c ell"
PACKAGECONFIG[btpclient] = "--enable-btpclient,--disable-btpclient, ell"
PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
-SRC_URI = "${KERNELORG_MIRROR}/linux/bluetooth/bluez-${PV}.tar.xz \
- file://init \
- file://run-ptest \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'file://0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch', d)} \
- file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
- file://0001-test-gatt-Fix-hung-issue.patch \
- "
+SRC_URI = "\
+ ${KERNELORG_MIRROR}/linux/bluetooth/bluez-${PV}.tar.xz \
+ file://out-of-tree.patch \
+ file://init \
+ file://run-ptest \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'file://0001-Allow-using-obexd-without-systemd-in-the-user-sessio.patch', d)} \
+ file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
+ file://0001-test-gatt-Fix-hung-issue.patch \
+ file://0001-Makefile.am-Fix-a-race-issue-for-tools.patch \
+ file://CVE-2018-10910.patch \
+ file://gcc9-fixes.patch \
+ file://0001-tools-Fix-build-after-y2038-changes-in-glibc.patch \
+ file://0001-tools-btpclient.c-include-signal.h.patch \
+"
S = "${WORKDIR}/bluez-${PV}"
CVE_PRODUCT = "bluez"
@@ -63,7 +70,6 @@ EXTRA_OECONF = "\
--enable-test \
--enable-datafiles \
--enable-library \
- --without-zsh-completion-dir \
"
# bluez5 builds a large number of useful utilities but does not