aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/avahi
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-01 16:27:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-02 14:47:26 +0100
commitd3fc33760a80b0a067b41ff88e99941f1c40c8f9 (patch)
tree0ea08fdf19bcc208501213f9354b69e58548fe12 /meta/recipes-connectivity/avahi
parent87780fc09b066525e47d0f50ee5497db54d304cd (diff)
downloadopenembedded-core-d3fc33760a80b0a067b41ff88e99941f1c40c8f9.tar.gz
avahi: enable service when using systemd
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta/recipes-connectivity/avahi')
-rw-r--r--meta/recipes-connectivity/avahi/avahi.inc18
-rw-r--r--meta/recipes-connectivity/avahi/avahi_0.6.30.bb2
2 files changed, 19 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/avahi/avahi.inc b/meta/recipes-connectivity/avahi/avahi.inc
index 099c5a4c2d..9e26a20f22 100644
--- a/meta/recipes-connectivity/avahi/avahi.inc
+++ b/meta/recipes-connectivity/avahi/avahi.inc
@@ -46,6 +46,24 @@ PACKAGES =+ "avahi-systemd avahi-daemon libavahi-common libavahi-core libavahi-c
FILES_avahi-systemd = "${base_libdir}/systemd"
RDEPENDS_avahi-systemd = "avahi-daemon"
+pkg_postinst_avahi-systemd() {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ systemctl enable avahi-daemon.service
+}
+
+pkg_postrm_avahi-systemd() {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ systemctl disable avahi-daemon.service
+}
+
FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
FILES_libavahi-ui = "${libdir}/libavahi-ui.so.*"
diff --git a/meta/recipes-connectivity/avahi/avahi_0.6.30.bb b/meta/recipes-connectivity/avahi/avahi_0.6.30.bb
index e63f40645e..23c0fa0533 100644
--- a/meta/recipes-connectivity/avahi/avahi_0.6.30.bb
+++ b/meta/recipes-connectivity/avahi/avahi_0.6.30.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
RDEPENDS_avahi-daemon = "sysvinit-pidof"
-PR = "r1"
+PR = "r3"
EXTRA_OECONF += "--disable-gtk3"