aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:42 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commitac510cb82c007f987b481df74c7a5fede81fa85a (patch)
tree740b8af961ee6872257947dc58313a2c501e8e33 /meta/recipes-bsp
parentc48f87a3fa9c61aaeedbcf5712a699c27d940a3b (diff)
downloadopenembedded-core-ac510cb82c007f987b481df74c7a5fede81fa85a.tar.gz
qemu-config: turn into distcc-config and a package group
* Create a new packagegroup-core-device-devel which pulls in everything that qemu-config used to, with the exception of anjuta-remote-run - this is unlikely to be widely used * Move the remainder of qemu-config to distcc-config and allow DISTCC_HOSTS to be configured via a variable of the same name * Use SUMMARY instead of DESCRIPTION for single-line description since DESCRIPTION is defaulted from SUMMARY if not set Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb23
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config/distcc.sh4
2 files changed, 0 insertions, 27 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
deleted file mode 100644
index 3ed07df91a..0000000000
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
-
-PR = "r25"
-
-SRC_URI = "file://distcc.sh"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -d ${D}${sysconfdir}/profile.d
- install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
-}
-
-RDEPENDS_${PN} = "distcc oprofileui-server bash"
-
-inherit allarch
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/distcc.sh b/meta/recipes-bsp/qemu-config/qemu-config/distcc.sh
deleted file mode 100644
index a2b543d6b8..0000000000
--- a/meta/recipes-bsp/qemu-config/qemu-config/distcc.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-DISTCC_HOSTS="192.168.7.1"
-#DISTCC_VERBOSE="1"
-
-export DISTCC_HOSTS