aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>2013-09-12 06:31:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-14 08:22:11 +0100
commit9e963fe587dda3ce77707194fc5dd029188c76d8 (patch)
tree5e5fa1788d5662953ae6e2ba27325bdddf8b0b82 /meta/recipes-bsp
parent177bf318bcd3dd2bfb3bec094b1f5ccac7bdd9ac (diff)
downloadopenembedded-core-9e963fe587dda3ce77707194fc5dd029188c76d8.tar.gz
apmd: Add systemd support
-Remove dependency on meta-systemd Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/apmd/apmd-3.2.2-14/apmd.service7
-rw-r--r--meta/recipes-bsp/apmd/apmd_3.2.2-14.bb13
2 files changed, 18 insertions, 2 deletions
diff --git a/meta/recipes-bsp/apmd/apmd-3.2.2-14/apmd.service b/meta/recipes-bsp/apmd/apmd-3.2.2-14/apmd.service
new file mode 100644
index 0000000000..62d6af1019
--- /dev/null
+++ b/meta/recipes-bsp/apmd/apmd-3.2.2-14/apmd.service
@@ -0,0 +1,7 @@
+[Unit]
+Description=Advanced Power Management daemon
+After=remote-fs.target
+
+[Service]
+EnvironmentFile-= @SYSCONFDIR@/default/apmd
+ExecStart=@SBINDIR@/apmd -P @SYSCONFDIR@/apm/apmd_proxy $APMD
diff --git a/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb b/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb
index d025387c3d..8c4b75eb6d 100644
--- a/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb
+++ b/meta/recipes-bsp/apmd/apmd_3.2.2-14.bb
@@ -17,7 +17,8 @@ SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz;name=tarball \
file://init \
file://default \
file://apmd_proxy \
- file://apmd_proxy.conf"
+ file://apmd_proxy.conf \
+ file://apmd.service"
SRC_URI[tarball.md5sum] = "b1e6309e8331e0f4e6efd311c2d97fa8"
SRC_URI[tarball.sha256sum] = "7f7d9f60b7766b852881d40b8ff91d8e39fccb0d1d913102a5c75a2dbb52332d"
@@ -27,11 +28,14 @@ SRC_URI[patch.sha256sum] = "7905ff96be93d725544d0040e425c42f9c05580db3c272f11cff
S = "${WORKDIR}/apmd-3.2.2.orig"
-inherit update-rc.d
+inherit update-rc.d systemd
INITSCRIPT_NAME = "apmd"
INITSCRIPT_PARAMS = "defaults"
+SYSTEMD_SERVICE_${PN} = "apmd.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
do_compile() {
# apmd doesn't use whole autotools. Just libtool for installation
oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" apm apmd
@@ -63,6 +67,11 @@ do_install() {
cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd
chmod 755 ${D}${sysconfdir}/init.d/apmd
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/apmd.service ${D}${systemd_unitdir}/system/
+ sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
+ -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apmd.service
}
PACKAGES =+ "libapm libapm-dev libapm-staticdev apm"