aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2013-09-13 19:21:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-17 19:27:16 +0100
commit83cb07047658e2e2b2d721e1b01553d4df3d8636 (patch)
tree0ae5dde4625efd57288cbf3e139ca049accf0554 /meta/recipes-bsp
parenta99edb5552839fd50326dd3aa4ee2f36f6026882 (diff)
downloadopenembedded-core-83cb07047658e2e2b2d721e1b01553d4df3d8636.tar.gz
u-boot-fw-utils: reinstate target recipe for fw_printenv
The latest upgrade changed u-boot-fw-utils to u-boot-fw-utils-cross, which removed the on-target fw_printenv (and fw_setenv). Re-create the updated version of the u-boot-fw-utils recipe. U-Boot does try to strip the fw_printenv binary by default now. To avoid this, without patching the Makefile, we add HOSTSTRIP=true to EXTRA_OEMAKE. The new U-Boot do also require us to configure the build for a specific machine, thus we change the package arch.ยง Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
new file mode 100644
index 0000000000..f97df71a7f
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2013.07.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+SECTION = "bootloader"
+DEPENDS = "mtd-utils"
+
+# This revision corresponds to the tag "v2013.07"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
+
+PV = "v2013.07+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"