aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooperjr27@gmail.com>2012-09-07 18:42:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 12:09:46 +0100
commit5b6a8e987f9039aca63d97bc42421b78acab8a3d (patch)
treee5a002ca9df9ba95849294779c3e36d05c471ca3 /meta/recipes-bsp
parent13e6aa8bba6ab1ebba1efa23f94af379a8fcb6a9 (diff)
downloadopenembedded-core-5b6a8e987f9039aca63d97bc42421b78acab8a3d.tar.gz
u-boot: Use fw_env.config if available.
* Add support for board specific fw_env.config file if available. Signed-off-by: Franklin S. Cooper Jr <fcooper27jr@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc16
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.03.bb2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.06.bb2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb2
4 files changed, 14 insertions, 8 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index a8642f0b06..ae53b9019c 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -49,6 +49,11 @@ do_install () {
install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+ if [ -e ${WORKDIR}/fw_env.config ] ; then
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ fi
+
if [ "x${SPL_BINARY}" != "x" ]
then
install ${S}/${SPL_BINARY} ${D}/boot/${SPL_IMAGE}
@@ -56,16 +61,17 @@ do_install () {
fi
}
-FILES_${PN} = "/boot"
+FILES_${PN} = "/boot ${sysconfdir}"
FILESPATH =. "${FILE_DIRNAME}/u-boot-git/${MACHINE}:"
do_deploy () {
install -d ${DEPLOYDIR}
- install ${S}/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
+ install ${S}/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
- cd ${DEPLOYDIR}
- rm -f ${UBOOT_SYMLINK}
- ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+ cd ${DEPLOYDIR}
+ rm -f ${UBOOT_BINARY} ${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${UBOOT_BINARY}
if [ "x${SPL_BINARY}" != "x" ]
then
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
index 84653958c9..a9cbeca167 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
SRCREV = "19b54a701811220221fc4d5089a2bb18892018ca"
PV = "v2011.03+git${SRCPV}"
-PR = "r7"
+PR = "r8"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
index 9654795744..a115ed2801 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
SRCREV = "b1af6f532e0d348b153d5c148369229d24af361a"
PV = "v2011.06+git${SRCPV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
diff --git a/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb b/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb
index c4ec50d6aa..6c099b1603 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb
@@ -20,7 +20,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d"
PV = "v2012.04.01+git${SRCPV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"