aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-09-04 21:39:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-10 16:01:07 +0100
commitc5fff5748e0aaf7e135fdd464c2104b1d3cbfd5a (patch)
treeaf74a48255f11626ae0db6edcb42ab62d5439bac /meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
parent6126c6e4b9c40c222519914c8fe0a51f9eee8d41 (diff)
downloadopenembedded-core-c5fff5748e0aaf7e135fdd464c2104b1d3cbfd5a.tar.gz
u-boot, u-boot-fw-utils-cross, u-boot-mkimage: Upgrade to 2013.07
This upgrades the U-Boot based recipes for 2013.07 release. This removes the 2011.03, 2011.06 and 2013.01.01 versions so we keep a single one in core. The following recipes has been upgraded: - u-boot (remove old versions) - u-boot-mkimage (remove old versions) - u-boot-fw-utils -> u-boot-fw-utils-cross (renamed and reworked) The u-boot-fw-utils-cross recipe has been reworked as it uses the UBOOT_MACHINE to find default environment for use so it is indeed a cross binary and not a native one. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
index 0108e0059f..a1b1db9555 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
@@ -1,17 +1,18 @@
DESCRIPTION = "U-boot bootloader mkimage tool"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
- file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
SECTION = "bootloader"
-SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+# This revision corresponds to the tag "v2013.07"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
-SRC_URI[md5sum] = "8445162690052e6afd4b8f87af2bb557"
-SRC_URI[sha256sum] = "2bbd440c1b29928d230604eac372fda5152d3ae23f52b1910c77fc5bf531250b"
+PV = "v2013.07+git${SRCPV}"
-S = "${WORKDIR}/u-boot-${PV}"
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
-BBCLASSEXTEND = "native nativesdk"
+S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
@@ -25,3 +26,4 @@ do_install () {
ln -sf uboot-mkimage ${D}${bindir}/mkimage
}
+BBCLASSEXTEND = "native nativesdk"