aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb
diff options
context:
space:
mode:
authorRadu Moisan <radu.moisan@intel.com>2013-03-13 17:21:08 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:17:33 +0000
commit8b44f27730d8d58923bf94dd3e06ce2cb733c974 (patch)
tree4db6dadf4ab06825f071e8f21db61eb4fcee91e0 /meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb
parentad48b2e32b640c1ca264c0b3b0038484facfd867 (diff)
downloadopenembedded-core-8b44f27730d8d58923bf94dd3e06ce2cb733c974.tar.gz
u-boot-mkimage: Upgrade to v2013.01.01
Signed-off-by: Radu Moisan <radu.moisan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb
new file mode 100644
index 0000000000..2b39998a8f
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.01.01.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+SECTION = "bootloader"
+
+# This is needs to be validated among supported BSP's before we can
+# make it default
+DEFAULT_PREFERENCE = "-1"
+
+# This revision corresponds to the tag "v2013.01.01"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "e8ae0fa5edd152b2b29c470b88429be4cdcd2c46"
+
+PV = "v2013.01.01+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"