aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/lrzsz
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-02-09 18:13:50 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-12 00:31:43 +0000
commit92a9d59fccdfb6587fbd12f686899a8ace5e1d2f (patch)
treeee21a7f2eff64edb141297e75cfda174b8e45bf9 /meta/recipes-bsp/lrzsz
parent6f6bffe5df1edf10056f42d2c95ae68b6bb918f9 (diff)
downloadopenembedded-core-92a9d59fccdfb6587fbd12f686899a8ace5e1d2f.tar.gz
recipes: pre/post actions
A number of the recipes did not properly label their pre and post actions, causing the actions to occur in all split packages. This was corrected by defaulting to _${PN} in most cases. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-bsp/lrzsz')
-rw-r--r--meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb b/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
index 6d08084b19..4cefdb7966 100644
--- a/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
+++ b/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
@@ -28,13 +28,13 @@ do_install() {
install -m 0755 src/lrz src/lsz ${D}${bindir}/
}
-pkg_postinst() {
+pkg_postinst_${PN}() {
for util in rz rx rb sz sx sb; do
update-alternatives --install ${bindir}/$util $util lrz 100
done
}
-pkg_postrm() {
+pkg_postrm_${PN}() {
for util in rz rx rb sz sx sb; do
update-alternatives --remove $util ${bindir}/lrz
done