aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-12-15 22:12:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-16 15:33:53 +0000
commitbc046c58c8f3c462972e9004dda2612b58376492 (patch)
tree07e2d83d7ea7bf646ea5c1173927dd9c0122ed39 /meta/recipes-bsp/grub
parent2c2770f89b3331f635647ba1ef87d8f63cfcdfe2 (diff)
downloadopenembedded-core-bc046c58c8f3c462972e9004dda2612b58376492.tar.gz
grub-efi: specify prefix so it can find grub.cfg
Specify /EFI/BOOT as the grub prefix so the grub efi payload can find the grub.cfg in the same directory. Ultimately, it might make more sense to install the grub tools and the grub-core modules to sysroot and make the grub-efi bbclass generate the image in the required format as part of the bootimg generation. However, bootimg is currently the only user, so make the correction here to resolve the immediate issue. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub')
-rw-r--r--meta/recipes-bsp/grub/grub-efi-native_1.99.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi-native_1.99.bb b/meta/recipes-bsp/grub/grub-efi-native_1.99.bb
index c86cf50082..9183812d5d 100644
--- a/meta/recipes-bsp/grub/grub-efi-native_1.99.bb
+++ b/meta/recipes-bsp/grub/grub-efi-native_1.99.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
# FIXME: We should be able to optionally drop freetype as a dependency
DEPENDS = "help2man-native"
RDEPENDS_${PN} = "diffutils freetype"
-PR = "r1"
+PR = "r2"
# Native packages do not normally rebuild when the target changes.
# Ensure this is built once per HOST-TARGET pair.
@@ -58,7 +58,7 @@ EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
--target=${GRUB_TARGET} --enable-efiemu=no --program-prefix=''"
do_mkimage() {
- ./grub-mkimage -p / -d ./grub-core/ \
+ ./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \
-O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
boot linux fat serial part_msdos normal efi_gop
}