aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-03-26 09:51:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-26 17:50:54 +0000
commit11ba0231244b8a27939969353e3aa668ce78f7c6 (patch)
treeea78e87c4bd84eee50c1070d0869a2a766e20682 /meta/recipes-bsp/grub
parentd569f44c296f6de1f7bb6ad9f581c237d5947321 (diff)
downloadopenembedded-core-11ba0231244b8a27939969353e3aa668ce78f7c6.tar.gz
grub-efi-native_2.00.bb: fix a build issue
Due to recent change in the oecore layer grub-efi recipe uses separate builddir and the paths used in the do_deply need to change accordingly. This change avoids this build issue: install: cannot stat `/build-fri2/tmp/work/x86_64-linux/grub-efi-i586-native/2.00-r1/grub-2.00/bootia32.efi': No such file or directory ERROR: Function failed: do_deploy (see /build-fri2/tmp/work/x86_64-linux/grub-efi-i586-native/2.00-r1/temp/log.do_deploy.5875 for further information) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub')
-rw-r--r--meta/recipes-bsp/grub/grub-efi-native_2.00.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi-native_2.00.bb b/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
index 14ab9ea7b9..6f8ba8e84f 100644
--- a/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
@@ -71,7 +71,7 @@ do_mkimage() {
addtask mkimage after do_compile before do_install
do_deploy() {
- install -m 644 ${S}/${GRUB_IMAGE} ${DEPLOYDIR}
+ install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
}
addtask deploy after do_install before do_build