aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-09-14 12:48:27 +0300
committerSaul Wold <sgw@linux.intel.com>2012-09-18 07:44:13 -0700
commit1773a98b68dd223b016fe408b022c2c5475669c2 (patch)
treef6e97b50f47ed2c36b3a410fcb01fdcc41b16e52 /meta/recipes-bsp/grub/grub-efi-native_2.00.bb
parent08dbc9790074fdb315d286849afbbda72d19cbd6 (diff)
downloadopenembedded-core-1773a98b68dd223b016fe408b022c2c5475669c2.tar.gz
grub: disable lzma, device-mapper, zfs and nvpair
check-if-liblzma-is-disabled.patch: added - add support for the --enable_liblzma option [YOCTO #2750] Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi-native_2.00.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi-native_2.00.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi-native_2.00.bb b/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
index 776bf23f2d..14ab9ea7b9 100644
--- a/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
# FIXME: We should be able to optionally drop freetype as a dependency
DEPENDS = "autogen-native"
RDEPENDS_${PN} = "diffutils freetype"
-PR = "r0"
+PR = "r1"
# Native packages do not normally rebuild when the target changes.
# Ensure this is built once per HOST-TARGET pair.
@@ -26,6 +26,7 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
file://grub-2.00-fpmath-sse-387-fix.patch \
file://grub-2.00-fix-enable_execute_stack-check.patch \
file://grub-2.00-disable-help2man.patch \
+ file://check-if-liblzma-is-disabled.patch \
file://grub-no-unused-result.patch \
"
SRC_URI[md5sum] = "e927540b6eda8b024fb0391eeaa4091c"
@@ -59,7 +60,8 @@ inherit native
inherit deploy
EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
- --target=${GRUB_TARGET} --enable-efiemu=no --program-prefix=''"
+ --target=${GRUB_TARGET} --enable-efiemu=no --program-prefix='' \
+ --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
do_mkimage() {
./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \