aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/eee-acpi-scripts
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-bsp/eee-acpi-scripts
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/eee-acpi-scripts')
-rw-r--r--meta/recipes-bsp/eee-acpi-scripts/eee-acpi-scripts_git.bb35
-rw-r--r--meta/recipes-bsp/eee-acpi-scripts/files/policy-funcs8
-rw-r--r--meta/recipes-bsp/eee-acpi-scripts/files/powerbtn.patch20
-rw-r--r--meta/recipes-bsp/eee-acpi-scripts/files/remove-doc-check.patch60
4 files changed, 123 insertions, 0 deletions
diff --git a/meta/recipes-bsp/eee-acpi-scripts/eee-acpi-scripts_git.bb b/meta/recipes-bsp/eee-acpi-scripts/eee-acpi-scripts_git.bb
new file mode 100644
index 0000000000..4c26504bd3
--- /dev/null
+++ b/meta/recipes-bsp/eee-acpi-scripts/eee-acpi-scripts_git.bb
@@ -0,0 +1,35 @@
+SECTION = "base"
+DESCRIPTION = "eeePC specific ACPI scripts"
+LICENSE="GPL"
+
+PV = "0.0+git${SRCREV}"
+PR = "r3"
+
+RDEPENDS = "pm-utils"
+
+SRC_URI = "git://git.debian.org/git/debian-eeepc/eeepc-acpi-scripts.git;protocol=git \
+ file://remove-doc-check.patch;patch=1 \
+ file://powerbtn.patch;patch=1 \
+ file://policy-funcs "
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} = "${datadir}/acpi-support/ \
+ ${datadir}/eeepc-acpi-scripts \
+ ${sysconfdir}/default/ \
+ ${sysconfdir}/acpi/"
+
+do_install () {
+ install -d ${D}${sysconfdir}/default/
+ install -d ${D}${sysconfdir}/acpi/actions/
+ install -d ${D}${sysconfdir}/acpi/events/
+ install -d ${D}${sysconfdir}/acpi/lib/
+ install -d ${D}${datadir}/eeepc-acpi-scripts/
+ install -d ${D}${datadir}/acpi-support/
+ install -m 644 ${S}/events/* ${D}${sysconfdir}/acpi/events/
+ install -m 644 ${S}/lib/* ${D}${sysconfdir}/acpi/lib/
+ install ${S}/actions/* ${D}${sysconfdir}/acpi/actions/
+ install -m 0644 ${S}/functions.sh ${D}${datadir}/eeepc-acpi-scripts/
+ install -m 0644 ${WORKDIR}/policy-funcs ${D}${datadir}/acpi-support/
+ install -m 0644 ${S}/debian/eeepc-acpi-scripts.default ${D}${sysconfdir}/default/
+}
diff --git a/meta/recipes-bsp/eee-acpi-scripts/files/policy-funcs b/meta/recipes-bsp/eee-acpi-scripts/files/policy-funcs
new file mode 100644
index 0000000000..fd099df0d8
--- /dev/null
+++ b/meta/recipes-bsp/eee-acpi-scripts/files/policy-funcs
@@ -0,0 +1,8 @@
+CheckPolicy() {
+ if pidof gnome-power-manager kpowersave > /dev/null ||
+ (pidof dcopserver > /dev/null && test -x /usr/bin/dcop && /usr/bin/dcop kded kded loadedModules | grep -q klaptopdaemon) ; then
+ echo 0;
+ else
+ echo 1;
+ fi
+}
diff --git a/meta/recipes-bsp/eee-acpi-scripts/files/powerbtn.patch b/meta/recipes-bsp/eee-acpi-scripts/files/powerbtn.patch
new file mode 100644
index 0000000000..3f79c3e610
--- /dev/null
+++ b/meta/recipes-bsp/eee-acpi-scripts/files/powerbtn.patch
@@ -0,0 +1,20 @@
+---
+ actions/power.sh | 3 +++
+ events/powerbtn | 2 ++
+ 2 files changed, 5 insertions(+)
+
+Index: git/events/powerbtn
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/events/powerbtn 2008-10-08 17:43:35.000000000 +0200
+@@ -0,0 +1,2 @@
++event=button/power PWRF
++action=/etc/acpi/actions/power.sh
+Index: git/actions/power.sh
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/actions/power.sh 2008-10-08 17:45:26.000000000 +0200
+@@ -0,0 +1,3 @@
++#!/bin/sh
++
++/sbin/shutdown -h now "Power button pressed"
diff --git a/meta/recipes-bsp/eee-acpi-scripts/files/remove-doc-check.patch b/meta/recipes-bsp/eee-acpi-scripts/files/remove-doc-check.patch
new file mode 100644
index 0000000000..8f6c4fcaad
--- /dev/null
+++ b/meta/recipes-bsp/eee-acpi-scripts/files/remove-doc-check.patch
@@ -0,0 +1,60 @@
+---
+ actions/hotkey.sh | 3 ---
+ actions/suspend.sh | 3 ---
+ actions/vga-toggle.sh | 3 ---
+ actions/volume.sh | 3 ---
+ 4 files changed, 12 deletions(-)
+
+Index: git/actions/hotkey.sh
+===================================================================
+--- git.orig/actions/hotkey.sh 2008-09-25 11:00:58.000000000 +0200
++++ git/actions/hotkey.sh 2008-09-25 11:01:04.000000000 +0200
+@@ -1,8 +1,5 @@
+ #!/bin/sh
+
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ . /etc/default/eeepc-acpi-scripts
+ . /usr/share/eeepc-acpi-scripts/functions.sh
+ . /etc/acpi/lib/notify.sh
+Index: git/actions/suspend.sh
+===================================================================
+--- git.orig/actions/suspend.sh 2008-09-25 11:00:32.000000000 +0200
++++ git/actions/suspend.sh 2008-09-25 11:00:37.000000000 +0200
+@@ -1,8 +1,5 @@
+ #!/bin/sh
+
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ if (runlevel | grep -q [06]) || (pidof '/sbin/shutdown' > /dev/null); then
+ exit 0
+ fi
+Index: git/actions/vga-toggle.sh
+===================================================================
+--- git.orig/actions/vga-toggle.sh 2008-09-25 11:02:00.000000000 +0200
++++ git/actions/vga-toggle.sh 2008-09-25 11:02:06.000000000 +0200
+@@ -1,8 +1,5 @@
+ #!/bin/sh
+
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ . /etc/default/eeepc-acpi-scripts
+
+ # return: 0 on disconnect, 1 on connected vga, 2 else
+Index: git/actions/volume.sh
+===================================================================
+--- git.orig/actions/volume.sh 2008-09-25 11:02:13.000000000 +0200
++++ git/actions/volume.sh 2008-09-25 11:02:19.000000000 +0200
+@@ -2,9 +2,6 @@
+
+ # Volume controls
+
+-# do nothing if package is removed
+-[ -d /usr/share/doc/eeepc-acpi-scripts ] || exit 0
+-
+ . /etc/default/eeepc-acpi-scripts
+ . /usr/share/eeepc-acpi-scripts/functions.sh
+ . /etc/acpi/lib/notify.sh