aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-06-07 15:28:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-07 15:58:55 +0100
commitcbd6a2de4d8bda44f1d53956acc49a4bef810e95 (patch)
tree3b2a1e8e250e2fd72e512412a4983745bfa6d236 /meta/lib/oeqa
parent2a1e8e2c9ff2caa6c207d8fe0d517e472715d1d1 (diff)
downloadopenembedded-core-cbd6a2de4d8bda44f1d53956acc49a4bef810e95.tar.gz
oeqa/selftest/recipetool: actually fix create_github test
The Meson revision was locked down but the license list change wasn't actually committed... Also specify the exact path for recipetool to write to, for clarity. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa')
-rw-r--r--meta/lib/oeqa/selftest/recipetool.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/lib/oeqa/selftest/recipetool.py b/meta/lib/oeqa/selftest/recipetool.py
index 312684be27..0ec8381655 100644
--- a/meta/lib/oeqa/selftest/recipetool.py
+++ b/meta/lib/oeqa/selftest/recipetool.py
@@ -448,10 +448,10 @@ class RecipetoolTests(RecipetoolBase):
os.makedirs(temprecipe)
recipefile = os.path.join(temprecipe, 'meson_git.bb')
srcuri = 'https://github.com/mesonbuild/meson;rev=0.32.0'
- result = runCmd(['recipetool', 'create', '-o', temprecipe, srcuri])
+ result = runCmd(['recipetool', 'create', '-o', recipefile, srcuri])
self.assertTrue(os.path.isfile(recipefile))
checkvars = {}
- checkvars['LICENSE'] = set(['Apache-2.0', 'Unknown'])
+ checkvars['LICENSE'] = set(['Apache-2.0'])
checkvars['SRC_URI'] = 'git://github.com/mesonbuild/meson;protocol=https'
inherits = ['setuptools']
self._test_recipe_contents(recipefile, checkvars, inherits)