aboutsummaryrefslogtreecommitdiffstats
path: root/meta/conf/layer.conf
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-25 15:58:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-26 14:54:53 +0100
commit7069c7ef829f56ae6dd0dab5e583342f351274ed (patch)
tree77ebd3cad8502a4064abf6ad66c5d6831fbd9f62 /meta/conf/layer.conf
parentfab44bdb346533edd4f702a83523d7c2414f74e5 (diff)
downloadopenembedded-core-7069c7ef829f56ae6dd0dab5e583342f351274ed.tar.gz
layer.conf: allow other layers to depend on this version
Set LAYERVERSION and rename the collection to "core". Given changes such as the tabs to spaces cleanup for python functions in the current version, this allows other layers to depend on this version of OE-Core specifically should they choose to do so, by specifying the following in their own layer.conf: LAYERDEPENDS_layername = "core:1" Where layername is whatever value is being added to BBFILE_COLLECTIONS. (This change does nothing unless a layer has LAYERDEPENDS set.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/conf/layer.conf')
-rw-r--r--meta/conf/layer.conf10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
index ed50f1c509..78ceae9db6 100644
--- a/meta/conf/layer.conf
+++ b/meta/conf/layer.conf
@@ -3,9 +3,13 @@ BBPATH .= ":${LAYERDIR}"
# We have a packages directory, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
-BBFILE_COLLECTIONS += "normal"
-BBFILE_PATTERN_normal := "^${LAYERDIR}/"
-BBFILE_PRIORITY_normal = "5"
+BBFILE_COLLECTIONS += "core"
+BBFILE_PATTERN_core := "^${LAYERDIR}/"
+BBFILE_PRIORITY_core = "5"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_core = "1"
# Set a variable to get to the top of the metadata location
COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'