aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-09-21 15:17:23 +0000
committerRichard Purdie <richard@openedhand.com>2006-09-21 15:17:23 +0000
commit5cacd3ea7efd69e57979d962616bf87c521c6f8b (patch)
treea379a06824d2194bf5d684f80394c587e5394795 /meta/classes
parent4471ca5bf7e65c8dfd315e7a0ad532ee598fe4d7 (diff)
downloadopenembedded-core-5cacd3ea7efd69e57979d962616bf87c521c6f8b.tar.gz
Remove unneeded classes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@742 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/e.bbclass36
-rw-r--r--meta/classes/efl.bbclass49
-rw-r--r--meta/classes/gpe.bbclass17
-rw-r--r--meta/classes/manifest.bbclass80
-rw-r--r--meta/classes/nslu2-jffs2-image.bbclass18
-rw-r--r--meta/classes/nslu2-mirrors.bbclass4
-rw-r--r--meta/classes/nslu2-ramdisk-image.bbclass18
-rw-r--r--meta/classes/nylon-mirrors.bbclass6
-rw-r--r--meta/classes/opie.bbclass105
-rw-r--r--meta/classes/opie_i18n.bbclass163
-rw-r--r--meta/classes/palmtop.bbclass20
-rw-r--r--meta/classes/qmake-base.bbclass44
-rw-r--r--meta/classes/qmake.bbclass57
-rw-r--r--meta/classes/qpf.bbclass36
-rw-r--r--meta/classes/qt3e.bbclass11
-rw-r--r--meta/classes/qt3x11.bbclass15
-rw-r--r--meta/classes/qt4x11.bbclass17
-rw-r--r--meta/classes/wrt-image.bbclass33
18 files changed, 0 insertions, 729 deletions
diff --git a/meta/classes/e.bbclass b/meta/classes/e.bbclass
deleted file mode 100644
index 008e3f2dc1..0000000000
--- a/meta/classes/e.bbclass
+++ /dev/null
@@ -1,36 +0,0 @@
-HOMEPAGE = "http://www.enlightenment.org"
-SECTION = "e/apps"
-
-inherit autotools pkgconfig binconfig
-
-do_prepsources () {
- make clean distclean || true
-}
-addtask prepsources after do_fetch before do_unpack
-
-def binconfig_suffix(d):
- import bb
- return ["","-native"][bb.data.inherits_class('native', d)]
-
-export CURL_CONFIG = "${STAGING_BINDIR}/curl-config${@binconfig_suffix(d)}"
-export EDB_CONFIG = "${STAGING_BINDIR}/edb-config${@binconfig_suffix(d)}"
-export EET_CONFIG = "${STAGING_BINDIR}/eet-config${@binconfig_suffix(d)}"
-export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config${@binconfig_suffix(d)}"
-export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config${@binconfig_suffix(d)}"
-export EMBRYO_CONFIG = "${STAGING_BINDIR}/embryo-config${@binconfig_suffix(d)}"
-export ENGRAVE_CONFIG = "${STAGING_BINDIR}/engrave-config${@binconfig_suffix(d)}"
-export ENLIGHTENMENT_CONFIG = "${STAGING_BINDIR}/enlightenment-config${@binconfig_suffix(d)}"
-export EPSILON_CONFIG = "${STAGING_BINDIR}/epsilon-config${@binconfig_suffix(d)}"
-export EPEG_CONFIG = "${STAGING_BINDIR}/epeg-config${@binconfig_suffix(d)}"
-export ESMART_CONFIG = "${STAGING_BINDIR}/esmart-config${@binconfig_suffix(d)}"
-export FREETYPE_CONFIG = "${STAGING_BINDIR}/freetype-config${@binconfig_suffix(d)}"
-export IMLIB2_CONFIG = "${STAGING_BINDIR}/imlib2-config${@binconfig_suffix(d)}"
-
-do_compile_prepend() {
- find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
- find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
-}
-
-PACKAGES = "${PN} ${PN}-themes"
-FILES_${PN} = "${libdir}/lib*.so*"
-FILES_${PN}-themes = "${datadir}/${PN}/themes ${datadir}/${PN}/data ${datadir}/${PN}/fonts ${datadir}/${PN}/pointers ${datadir}/${PN}/images ${datadir}/${PN}/users ${datadir}/${PN}/images ${datadir}/${PN}/styles"
diff --git a/meta/classes/efl.bbclass b/meta/classes/efl.bbclass
deleted file mode 100644
index c258758d30..0000000000
--- a/meta/classes/efl.bbclass
+++ /dev/null
@@ -1,49 +0,0 @@
-inherit e
-
-SECTION = "e/libs"
-
-SRCNAME = "${@bb.data.getVar('PN', d, 1).replace('-native', '')}"
-SRC_URI = "${E_URI}/${SRCNAME}-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-INHIBIT_AUTO_STAGE_INCLUDES = "1"
-INHIBIT_NATIVE_STAGE_INSTALL = "1"
-
-libdirectory = "src/lib"
-libraries = "lib${SRCNAME}"
-headers = "${@bb.data.getVar('SRCNAME',d,1).capitalize()}.h"
-
-do_stage_append () {
- for i in ${libraries}
- do
- oe_libinstall -C ${libdirectory} $i ${STAGING_LIBDIR}
- done
- for i in ${headers}
- do
- install -m 0644 ${libdirectory}/$i ${STAGING_INCDIR}
- done
-
- # Install binaries automatically for native builds
- if [ "${@binconfig_suffix(d)}" = "-native" ]
- then
-
- # Most EFL binaries start with the package name
- for i in src/bin/${SRCNAME}*
- do
- if [ -x $i -a -f $i ]
- then
-
- # Don't install anything with an extension (.so, etc)
- if echo $i | grep -v \\.
- then
- ${HOST_SYS}-libtool --mode=install install -m 0755 $i ${STAGING_BINDIR}
- fi
- fi
- done
- fi
-}
-
-PACKAGES = "${PN} ${PN}-themes ${PN}-dev ${PN}-examples"
-FILES_${PN}-dev = "${bindir}/${PN}-config ${libdir}/pkgconfig ${libdir}/lib*.?a ${libdir}/lib*.a ${includedir}"
-FILES_${PN}-examples = "${bindir} ${datadir}"
-
diff --git a/meta/classes/gpe.bbclass b/meta/classes/gpe.bbclass
deleted file mode 100644
index 861ec416a0..0000000000
--- a/meta/classes/gpe.bbclass
+++ /dev/null
@@ -1,17 +0,0 @@
-DEPENDS_prepend = "coreutils-native virtual/libintl intltool-native "
-GPE_TARBALL_SUFFIX ?= "gz"
-SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.${GPE_TARBALL_SUFFIX}"
-FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
-MAINTAINER ?= "GPE Team <gpe@handhelds.org>"
-
-inherit gettext
-
-gpe_do_compile() {
- oe_runmake PREFIX=${prefix}
-}
-
-gpe_do_install() {
- oe_runmake PREFIX=${prefix} DESTDIR=${D} install
-}
-
-EXPORT_FUNCTIONS do_compile do_install
diff --git a/meta/classes/manifest.bbclass b/meta/classes/manifest.bbclass
deleted file mode 100644
index 687f4b756e..0000000000
--- a/meta/classes/manifest.bbclass
+++ /dev/null
@@ -1,80 +0,0 @@
-
-python read_manifest () {
- import sys, bb.manifest
- mfn = bb.data.getVar("MANIFEST", d, 1)
- if os.access(mfn, os.R_OK):
- # we have a manifest, so emit do_stage and do_populate_pkgs,
- # and stuff some additional bits of data into the metadata store
- mfile = file(mfn, "r")
- manifest = bb.manifest.parse(mfile, d)
- if not manifest:
- return
-
- bb.data.setVar('manifest', manifest, d)
-}
-
-python parse_manifest () {
- manifest = bb.data.getVar("manifest", d)
- if not manifest:
- return
- for func in ("do_populate_staging", "do_populate_pkgs"):
- value = bb.manifest.emit(func, manifest, d)
- if value:
- bb.data.setVar("manifest_" + func, value, d)
- bb.data.delVarFlag("manifest_" + func, "python", d)
- bb.data.delVarFlag("manifest_" + func, "fakeroot", d)
- bb.data.setVarFlag("manifest_" + func, "func", 1, d)
- packages = []
- for l in manifest:
- if "pkg" in l and l["pkg"] is not None:
- packages.append(l["pkg"])
- bb.data.setVar("PACKAGES", " ".join(packages), d)
-}
-
-python __anonymous () {
- try:
- bb.build.exec_func('read_manifest', d)
- bb.build.exec_func('parse_manifest', d)
- except exceptions.KeyboardInterrupt:
- raise
- except Exception, e:
- bb.error("anonymous function: %s" % e)
- pass
-}
-
-#python do_populate_staging () {
-# if not bb.data.getVar('manifest', d):
-# bb.build.exec_func('do_emit_manifest', d)
-# if bb.data.getVar('do_stage', d):
-# bb.build.exec_func('do_stage', d)
-# else:
-# bb.build.exec_func('manifest_do_populate_staging', d)
-#}
-
-#addtask populate_pkgs after do_compile
-#python do_populate_pkgs () {
-# if not bb.data.getVar('manifest', d):
-# bb.build.exec_func('do_emit_manifest', d)
-# bb.build.exec_func('manifest_do_populate_pkgs', d)
-# bb.build.exec_func('package_do_shlibs', d)
-#}
-
-addtask emit_manifest
-python do_emit_manifest () {
-# FIXME: emit a manifest here
-# 1) adjust PATH to hit the wrapper scripts
- wrappers = bb.which(bb.data.getVar("BBPATH", d, 1), 'build/install', 0)
- path = (bb.data.getVar('PATH', d, 1) or '').split(':')
- path.insert(0, os.path.dirname(wrappers))
- bb.data.setVar('PATH', ':'.join(path), d)
-# 2) exec_func("do_install", d)
- bb.build.exec_func('do_install', d)
-# 3) read in data collected by the wrappers
- print("Got here2 213")
- bb.build.exec_func('read_manifest', d)
-# 4) mangle the manifest we just generated, get paths back into
-# our variable form
-# 5) write it back out
-# 6) re-parse it to ensure the generated functions are proper
- bb.build.exec_func('parse_manifest', d)
-}
diff --git a/meta/classes/nslu2-jffs2-image.bbclass b/meta/classes/nslu2-jffs2-image.bbclass
deleted file mode 100644
index 56ad0f0659..0000000000
--- a/meta/classes/nslu2-jffs2-image.bbclass
+++ /dev/null
@@ -1,18 +0,0 @@
-NSLU2_SLUGIMAGE_ARGS ?= ""
-
-nslu2_pack_image () {
- install -d ${DEPLOY_DIR_IMAGE}/slug
- install -m 0644 ${STAGING_LIBDIR}/nslu2-binaries/RedBoot \
- ${STAGING_LIBDIR}/nslu2-binaries/Trailer \
- ${STAGING_LIBDIR}/nslu2-binaries/SysConf \
- ${DEPLOY_DIR_IMAGE}/slug/
- install -m 0644 ${DEPLOY_DIR_IMAGE}/zImage-${IMAGE_BASENAME} ${DEPLOY_DIR_IMAGE}/slug/vmlinuz
- install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 ${DEPLOY_DIR_IMAGE}/slug/flashdisk.jffs2
- cd ${DEPLOY_DIR_IMAGE}/slug
- slugimage -p -b RedBoot -s SysConf -r Ramdisk:1,Flashdisk:flashdisk.jffs2 -t Trailer \
- -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.flashdisk.img ${NSLU2_SLUGIMAGE_ARGS}
- rm -rf ${DEPLOY_DIR_IMAGE}/slug
-}
-
-EXTRA_IMAGEDEPENDS += 'slugimage-native nslu2-linksys-firmware'
-IMAGE_POSTPROCESS_COMMAND += "nslu2_pack_image; "
diff --git a/meta/classes/nslu2-mirrors.bbclass b/meta/classes/nslu2-mirrors.bbclass
deleted file mode 100644
index 1181edc716..0000000000
--- a/meta/classes/nslu2-mirrors.bbclass
+++ /dev/null
@@ -1,4 +0,0 @@
-MIRRORS_append () {
-ftp://.*/.*/ http://sources.nslu2-linux.org/sources/
-http://.*/.*/ http://sources.nslu2-linux.org/sources/
-}
diff --git a/meta/classes/nslu2-ramdisk-image.bbclass b/meta/classes/nslu2-ramdisk-image.bbclass
deleted file mode 100644
index 0b545854fd..0000000000
--- a/meta/classes/nslu2-ramdisk-image.bbclass
+++ /dev/null
@@ -1,18 +0,0 @@
-NSLU2_SLUGIMAGE_ARGS ?= ""
-
-nslu2_pack_image () {
- install -d ${DEPLOY_DIR_IMAGE}/slug
- install -m 0644 ${STAGING_LIBDIR}/nslu2-binaries/RedBoot \
- ${STAGING_LIBDIR}/nslu2-binaries/Trailer \
- ${STAGING_LIBDIR}/nslu2-binaries/SysConf \
- ${DEPLOY_DIR_IMAGE}/slug/
- install -m 0644 ${DEPLOY_DIR_IMAGE}/zImage-${IMAGE_BASENAME} ${DEPLOY_DIR_IMAGE}/slug/vmlinuz
- install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ext2.gz ${DEPLOY_DIR_IMAGE}/slug/ramdisk.ext2.gz
- cd ${DEPLOY_DIR_IMAGE}/slug
- slugimage -p -b RedBoot -s SysConf -r Ramdisk:ramdisk.ext2.gz -t Trailer \
- -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.ramdisk.img ${NSLU2_SLUGIMAGE_ARGS}
- rm -rf ${DEPLOY_DIR_IMAGE}/slug
-}
-
-EXTRA_IMAGEDEPENDS += 'slugimage-native nslu2-linksys-firmware'
-IMAGE_POSTPROCESS_COMMAND += "nslu2_pack_image; "
diff --git a/meta/classes/nylon-mirrors.bbclass b/meta/classes/nylon-mirrors.bbclass
deleted file mode 100644
index 2986bd8f80..0000000000
--- a/meta/classes/nylon-mirrors.bbclass
+++ /dev/null
@@ -1,6 +0,0 @@
-MIRRORS_append () {
-ftp://.*/.*/ http://meshcube.org/nylon/stable/sources/
-http://.*/.*/ http://meshcube.org/nylon/stable/sources/
-ftp://.*/.*/ http://meshcube.org/nylon/unstable/sources/
-http://.*/.*/ http://meshcube.org/nylon/unstable/sources/
-} \ No newline at end of file
diff --git a/meta/classes/opie.bbclass b/meta/classes/opie.bbclass
deleted file mode 100644
index 6430d46d6a..0000000000
--- a/meta/classes/opie.bbclass
+++ /dev/null
@@ -1,105 +0,0 @@
-#
-# This oeclass takes care about some of the itchy details of installing parts
-# of Opie applications. Depending on quicklaunch or not, plugin or not, the
-# TARGET is either a shared object, a shared object with a link to quicklauncher,
-# or a usual binary.
-#
-# You have to provide two things: 1.) A proper SECTION field, and 2.) a proper APPNAME
-# Then opie.oeclass will:
-# * create the directory for the binary and install the binary file(s)
-# * for applications: create the directory for the .desktop and install the .desktop file
-# * for quicklauncher applications: create the startup symlink to the quicklauncher
-# You can override the automatic detection of APPTYPE, valid values are 'quicklaunch', 'binary', 'plugin'
-# You can override the default location of APPDESKTOP (<workdir>/apps/<section>/)
-#
-
-inherit palmtop
-
-# Note that when CVS changes to 1.2.2, the dash
-# should be removed from OPIE_CVS_PV to convert
-# to the standardised version format
-OPIE_CVS_PV = "1.2.2+cvs-${SRCDATE}"
-
-DEPENDS_prepend = "${@["libopie2 ", ""][(bb.data.getVar('PN', d, 1) == 'libopie2')]}"
-
-# to be consistent, put all targets into workdir
-# NOTE: leave one space at the end, other files are expecting that
-EXTRA_QMAKEVARS_POST += "DESTDIR=${S} "
-
-# Opie standard TAG value
-TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
-
-# plan for later:
-# add common scopes for opie applications, see qmake-native/common.pro
-# qmake should care about all the details then. qmake can do that, i know it :)
-#
-
-python opie_do_opie_install() {
- import os, shutil
- section = bb.data.getVar( "SECTION", d ).split( '/' )[1] or "Applications"
- section = section.title()
- if section in ( "Base", "Libs" ):
- bb.note( "Section = Base or Libs. Target won't be installed automatically." )
- return
-
- # SECTION : BINDIR DESKTOPDIR
- dirmap = { "Applets" : ( "/plugins/applets", None ),
- "Applications" : ( "<BINDIR>", "/apps/Applications" ),
- "Multimedia" : ( "<BINDIR>", "/apps/Applications" ),
- "Games" : ( "<BINDIR>", "/apps/Games" ),
- "Settings" : ( "<BINDIR>", "/apps/Settings" ),
- "Pim" : ( "<BINDIR>", "/apps/1Pim" ),
- "Examples" : ( "<BINDIR>", "/apps/Examples" ),
- "Shell" : ( "/bin", "/apps/Opie-SH" ),
- "Codecs" : ( "/plugins/codecs", None ),
- "Decorations" : ( "/plugins/decorations", None ),
- "Inputmethods" : ( "/plugins/inputmethods", None ),
- "Fontfactories" : ( "/plugins/fontfactories", None ),
- "Security" : ( "/plugins/security", None ),
- "Styles" : ( "/plugins/styles", None ),
- "Today" : ( "/plugins/today", None ),
- "Datebook" : ( "/plugins/holidays", None ),
- "Networksettings" : ( "/plugins/networksettings", None ) }
-
- if section not in dirmap:
- raise ValueError, "Unknown section '%s'. Valid sections are: %s" % ( section, dirmap.keys() )
-
- bindir, desktopdir = dirmap[section]
- APPNAME = bb.data.getVar( "APPNAME", d, True ) or bb.data.getVar( "PN", d, True )
- APPTYPE = bb.data.getVar( "APPTYPE", d, True )
- if not APPTYPE:
- if bindir == "<BINDIR>":
- APPTYPE = "quicklaunch"
- else:
- APPTYPE = "plugin"
-
- appmap = { "binary":"/bin", "quicklaunch":"/plugins/application" }
- if bindir == "<BINDIR>": bindir = appmap[APPTYPE]
-
- bb.note( "Section='%s', bindir='%s', desktopdir='%s', name='%s', type='%s'" %
- ( section, bindir, desktopdir, APPNAME, APPTYPE ) )
-
- S = bb.data.getVar( "S", d, 1 )
- D = "%s/image" % bb.data.getVar( "WORKDIR", d, True )
- WORKDIR = bb.data.getVar( "WORKDIR", d, True )
- palmtopdir = bb.data.getVar( "palmtopdir", d )
- APPDESKTOP = bb.data.getVar( "APPDESKTOP", d, True ) or "%s/%s" % ( WORKDIR, desktopdir )
-
- if desktopdir is not None:
- os.system( "install -d %s%s%s/" % ( D, palmtopdir, desktopdir ) )
- os.system( "install -m 0644 %s/%s.desktop %s%s%s/" % ( APPDESKTOP, APPNAME, D, palmtopdir, desktopdir ) )
-
- os.system( "install -d %s%s%s/" % ( D, palmtopdir, bindir ) )
-
- if APPTYPE == "binary":
- os.system( "install -m 0755 %s/%s %s%s%s/" % ( S, APPNAME, D, palmtopdir, bindir ) )
- elif APPTYPE == "quicklaunch":
- os.system( "install -m 0755 %s/lib%s.so %s%s%s/" % ( S, APPNAME, D, palmtopdir, bindir ) )
- os.system( "install -d %s%s/bin/" % ( D, palmtopdir ) )
- os.system( "ln -sf %s/bin/quicklauncher %s%s/bin/%s" % ( palmtopdir, D, palmtopdir, APPNAME ) )
- elif APPTYPE == "plugin":
- os.system( "install -m 0755 %s/lib%s.so %s%s%s/" % ( S, APPNAME, D, palmtopdir, bindir ) )
-}
-
-EXPORT_FUNCTIONS do_opie_install
-addtask opie_install after do_compile before do_populate_staging
diff --git a/meta/classes/opie_i18n.bbclass b/meta/classes/opie_i18n.bbclass
deleted file mode 100644
index cb3d07de75..0000000000
--- a/meta/classes/opie_i18n.bbclass
+++ /dev/null
@@ -1,163 +0,0 @@
-# classes/opie_i18n.oeclass Matthias 'CoreDump' Hentges 16-10-2004
-#
-# Automatically builds i18n ipks for opie packages. It downloads opie-i18n from opie CVS
-# and tries to guess the name of the .ts file based on the package name:
-# ${PN}.ts, lib${PN}.ts and opie-${PN}.ts are all valid. The .ts "guessing" can be
-# disabled by setting I18N_FILES in the .oe file.
-#
-# Todo:
-#
-
-I18N_STATS = "1"
-SRC_URI += "${HANDHELDS_CVS};module=opie/i18n"
-DEPENDS += "opie-i18n"
-
-die () {
- echo -e "opie_18n: ERROR: $1"
- exit 1
-}
-
-python do_build_opie_i18n_data() {
-
- import os, bb, re
- workdir = bb.data.getVar("WORKDIR", d, 1)
- packages = bb.data.getVar("PACKAGES", d, 1)
- files = bb.data.getVar("FILES", d, 1)
- section = bb.data.getVar("SECTION", d, 1)
- pn = bb.data.getVar("PN", d, 1)
- rdepends = bb.data.getVar("RDEPENDS", d, 1)
-
- if os.path.exists(workdir + "/PACKAGES.tmp"):
- fd = open(workdir + "/PACKAGES.tmp", 'r')
- lines = fd.readlines()
- fd.close()
-
- bb.data.setVar('PACKAGES', " ".join(lines).lower() + " " + packages, d)
-
- fd = open(workdir + "/FILES.tmp", 'r')
- lines = fd.readlines()
- fd.close()
-
- for l in lines:
- x = re.split("\#", l)
- bb.data.setVar('FILES_%s' % x[0].lower(), " " + x[1].strip('\n'), d)
- bb.data.setVar('SECTION_%s' % x[0].lower(), "opie/translations", d)
- bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d)
-
- bb.data.setVar('SECTION_%s' % pn, section, d)
- bb.data.setVar('RDEPENDS', rdepends, d)
- else:
- bb.note("No translations found for package " + pn)
-}
-
-do_build_opie_i18n () {
-
- cd "${WORKDIR}/i18n" || die "ERROR:\nCouldn't find Opies i18n sources in ${PN}/i18n\nMake sure that <inherit opie_i18n> or <inherit opie> is *below* <SRC_URIS =>!"
-
- if test -z "${I18N_FILES}"
- then
- package_name="`echo "${PN}"| sed "s/^opie\-//"`"
- package_name2="`echo "${PN}"| sed "s/^opie\-//;s/\-//"`"
- test "$package_name" != "$package_name2" && I18N_FILES="${package_name}.ts lib${package_name}.ts opie-${package_name}.ts ${package_name2}.ts lib${package_name2}.ts opie-${package_name2}.ts"
- test "$package_name" = "$package_name2" && I18N_FILES="${package_name}.ts lib${package_name}.ts opie-${package_name}.ts"
- echo -e "I18N Datafiles: ${I18N_FILES} (auto-detected)\nYou can overide the auto-detection by setting I18N_FILES in your .oe file"
- else
- echo "I18N Datafiles: ${I18N_FILES} (provided by .bb)"
- fi
-
- rm -f "${WORKDIR}/FILES.tmp" "${WORKDIR}/PACKAGES.tmp"
-
- echo -e "\nFILES is set to [${FILES}]\n"
-
- for file in ${I18N_FILES}
- do
- echo "Working on [$file]"
- for ts_file in `ls -1 */*.ts | egrep "/$file"`
- do
- echo -e "\tCompiling [$ts_file]"
- cd "${WORKDIR}/i18n/`dirname $ts_file`" || die "[${WORKDIR}/i18n/`dirname $ts_file`] not found"
- opie-lrelease "`basename $ts_file`" || die "lrelease failed! Make sure that <inherit opie_i18n> or <inherit opie> is *below* <DEPENDS =>!"
-
- # $lang is the language as in de_DE, $lang_sane replaces "_" with "-"
- # to allow packaging as "_" is not allowed in a package name
- lang="`echo "$ts_file" | sed -n "s#\(.*\)/\(.*\)#\1#p"`"
- lang_sane="`echo "$ts_file" | sed -n "s#\(.*\)/\(.*\)#\1#p"|sed s/\_/\-/`"
- echo -e "\tPackaging [`basename $ts_file`] for language [$lang]"
-
- install -d ${D}${palmtopdir}/i18n/$lang
- install -m 0644 ${WORKDIR}/i18n/$lang/.directory ${D}${palmtopdir}/i18n/$lang/
- install -m 0644 ${WORKDIR}/i18n/$lang/*.qm "${D}${palmtopdir}/i18n/$lang/"
-
- # As it is not possible to modify OE vars from within a _shell_ function,
- # some major hacking was needed. These two files will be read by the python
- # function do_build_opie_i18n_data() which sets the variables FILES_* and
- # PACKAGES as needed.
- echo -n "${PN}-${lang_sane} " >> "${WORKDIR}/PACKAGES.tmp"
- echo -e "${PN}-${lang_sane}#${palmtopdir}/i18n/$lang" >> "${WORKDIR}/FILES.tmp"
-
- ts_found_something=1
- done
-
- if test "$ts_found_something" != 1
- then
- echo -e "\tNo translations found"
- else
- ts_found_something=""
- ts_found="$ts_found $file"
- fi
-
- # Only used for debugging purposes
- test "${I18N_STATS}" = 1 && cd "${WORKDIR}/i18n"
-
- echo -e "Completed [$file]\n\n"
- done
-
- qt_dirs="apps bin etc lib pics plugins share sounds"
-
- for dir in $qt_dirs
- do
- dir_="$dir_ ${palmtopdir}/$dir "
- done
-
-
- # If we don't adjust FILES to exclude the i18n directory, we will end up with
- # _lots_ of empty i18n/$lang directories in the original .ipk.
- if (echo "${FILES}" | egrep "${palmtopdir}/? |${palmtopdir}/?$") &>/dev/null
- then
- echo "NOTE: FILES was set to ${palmtopdir} which would include the i18n directory"
- echo -e "\n\nI'll remove ${palmtopdir} from FILES and replace it with all directories"
- echo "below QtPalmtop, except i18n ($qt_dirs). See classes/opie_i18n.oeclass for details"
-
- # Removes /opt/QtPalmtop from FILES but keeps /opt/QtPalmtop/$some_dir
- FILES="`echo "$FILES"| sed "s#${palmtopdir}[/]\?\$\|${palmtopdir}[/]\? ##"`"
-
- echo "${PN}#$FILES $dir_" >> "${WORKDIR}/FILES.tmp"
- fi
-
- # This is the common case for OPIE apps which are installed by opie.oeclass magic
- if test -z "${FILES}"
- then
- echo "NOTE:"
- echo -e "Since FILES is empty, i'll add all directories below ${palmtopdir} to it,\nexcluding i18n: ( $qt_dirs )"
- echo "${PN}#$FILES $dir_" >> "${WORKDIR}/FILES.tmp"
- fi
-
- if ! test -e "${WORKDIR}/PACKAGES.tmp" -a "${I18N_STATS}" = 1
- then
- echo "No translations for package [${PN}]" >> /tmp/oe-i18n-missing.log
- else
- echo "Using [$ts_found ] for package [${PN}]" >> /tmp/oe-i18n.log
- fi
-
- # While this might not be very elegant, it safes a _ton_ of space (~30Mb) for
- # each opie package.
- for file in $(ls */*.ts | egrep -v "`echo "$ts_found"| sed "s/^\ //;s/\ /\|/"`")
- do
- rm "$file"
- done
-
- return 0
-}
-
-addtask build_opie_i18n before do_compile
-addtask build_opie_i18n_data after do_build_opie_i18n before do_compile
diff --git a/meta/classes/palmtop.bbclass b/meta/classes/palmtop.bbclass
deleted file mode 100644
index 9d54de8748..0000000000
--- a/meta/classes/palmtop.bbclass
+++ /dev/null
@@ -1,20 +0,0 @@
-# this build class sets up qmake variables to
-# * build using the Qt Windowing System (QWS)
-# * use qt
-# * link against supc++ instead of stdc++
-# * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
-# inherit this class to build programs against libqpe
-# inherit opie if you want to build programs against libopie2
-# don't override EXTRA_QMAKEVARS_POST, if you use inherit this class
-
-inherit qmake
-
-# special case for DISTRO = sharprom
-CPP_SUPPORT_LIB = "LIBS-=-lstdc++ LIBS+=-lsupc++"
-CPP_SUPPORT_LIB_sharprom = "LIBS-=-lstdc++"
-EXTRA_QMAKEVARS_POST += "DEFINES+=QWS CONFIG+=qt ${CPP_SUPPORT_LIB}"
-EXTRA_QMAKEVARS_POST += '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", "CONFIG-=thread",d)}'
-EXTRA_QMAKEVARS_POST += "${@["LIBS+=-lqpe ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
-DEPENDS_prepend = "${@["virtual/libqpe1 uicmoc-native ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
-
-FILES_${PN} = "${palmtopdir}"
diff --git a/meta/classes/qmake-base.bbclass b/meta/classes/qmake-base.bbclass
deleted file mode 100644
index 36ecfb622f..0000000000
--- a/meta/classes/qmake-base.bbclass
+++ /dev/null
@@ -1,44 +0,0 @@
-DEPENDS_prepend = "qmake-native "
-
-OE_QMAKE_PLATFORM = "${TARGET_OS}-oe-g++"
-QMAKESPEC := "${QMAKE_MKSPEC_PATH}/${OE_QMAKE_PLATFORM}"
-
-# We override this completely to eliminate the -e normally passed in
-EXTRA_OEMAKE = ' MAKEFLAGS= '
-
-export OE_QMAKE_CC="${CC}"
-export OE_QMAKE_CFLAGS="${CFLAGS}"
-export OE_QMAKE_CXX="${CXX}"
-export OE_QMAKE_CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
-export OE_QMAKE_LDFLAGS="${LDFLAGS}"
-export OE_QMAKE_LINK="${CCLD}"
-export OE_QMAKE_AR="${AR}"
-export OE_QMAKE_STRIP="${STRIP}"
-export OE_QMAKE_UIC="${STAGING_BINDIR}/uic"
-export OE_QMAKE_MOC="${STAGING_BINDIR}/moc"
-export OE_QMAKE_RCC="non-existant"
-export OE_QMAKE_QMAKE="${STAGING_BINDIR}/qmake"
-export OE_QMAKE_RPATH="-Wl,-rpath-link,"
-
-# default to qte2 via bb.conf, inherit qt3x11 to configure for qt3x11
-export OE_QMAKE_INCDIR_QT="${QTDIR}/include"
-export OE_QMAKE_LIBDIR_QT="${QTDIR}/lib"
-export OE_QMAKE_LIBS_QT="qte"
-export OE_QMAKE_LIBS_X11=""
-
-oe_qmake_mkspecs () {
- mkdir -p mkspecs/${OE_QMAKE_PLATFORM}
- for f in ${QMAKE_MKSPEC_PATH}/${OE_QMAKE_PLATFORM}/*; do
- if [ -L $f ]; then
- lnk=`readlink $f`
- if [ -f mkspecs/${OE_QMAKE_PLATFORM}/$lnk ]; then
- ln -s $lnk mkspecs/${OE_QMAKE_PLATFORM}/`basename $f`
- else
- cp $f mkspecs/${OE_QMAKE_PLATFORM}/
- fi
- else
- cp $f mkspecs/${OE_QMAKE_PLATFORM}/
- fi
- done
-}
-
diff --git a/meta/classes/qmake.bbclass b/meta/classes/qmake.bbclass
deleted file mode 100644
index 4f2fceff35..0000000000
--- a/meta/classes/qmake.bbclass
+++ /dev/null
@@ -1,57 +0,0 @@
-inherit qmake-base
-
-qmake_do_configure() {
- case ${QMAKESPEC} in
- *linux-oe-g++|*linux-uclibc-oe-g++|*linux-gnueabi-oe-g++)
- ;;
- *-oe-g++)
- die Unsupported target ${TARGET_OS} for oe-g++ qmake spec
- ;;
- *)
- oenote Searching for qmake spec file
- paths="${QMAKE_MKSPEC_PATH}/qws/${TARGET_OS}-${TARGET_ARCH}-g++"
- paths="${QMAKE_MKSPEC_PATH}/${TARGET_OS}-g++ $paths"
-
- if (echo "${TARGET_ARCH}"|grep -q 'i.86'); then
- paths="${QMAKE_MKSPEC_PATH}/qws/${TARGET_OS}-x86-g++ $paths"
- fi
- for i in $paths; do
- if test -e $i; then
- export QMAKESPEC=$i
- break
- fi
- done
- ;;
- esac
-
- oenote "using qmake spec in ${QMAKESPEC}, using profiles '${QMAKE_PROFILES}'"
-
- if [ -z "${QMAKE_PROFILES}" ]; then
- PROFILES="`ls *.pro`"
- else
- PROFILES="${QMAKE_PROFILES}"
- fi
-
- if [ -z "$PROFILES" ]; then
- die "QMAKE_PROFILES not set and no profiles found in $PWD"
- fi
-
- if [ ! -z "${EXTRA_QMAKEVARS_POST}" ]; then
- AFTER="-after"
- QMAKE_VARSUBST_POST="${EXTRA_QMAKEVARS_POST}"
- oenote "qmake postvar substitution: ${EXTRA_QMAKEVARS_POST}"
- fi
-
- if [ ! -z "${EXTRA_QMAKEVARS_PRE}" ]; then
- QMAKE_VARSUBST_PRE="${EXTRA_QMAKEVARS_PRE}"
- oenote "qmake prevar substitution: ${EXTRA_QMAKEVARS_PRE}"
- fi
-
-#oenote "Calling '${OE_QMAKE_QMAKE} -makefile -spec ${QMAKESPEC} -o Makefile $QMAKE_VARSUBST_PRE $AFTER $PROFILES $QMAKE_VARSUBST_POST'"
- unset QMAKESPEC || true
- ${OE_QMAKE_QMAKE} -makefile -spec ${QMAKESPEC} -o Makefile $QMAKE_VARSUBST_PRE $AFTER $PROFILES $QMAKE_VARSUBST_POST || die "Error calling ${OE_QMAKE_QMAKE} on $PROFILES"
-}
-
-EXPORT_FUNCTIONS do_configure
-
-addtask configure after do_unpack do_patch before do_compile
diff --git a/meta/classes/qpf.bbclass b/meta/classes/qpf.bbclass
deleted file mode 100644
index d6e58871d5..0000000000
--- a/meta/classes/qpf.bbclass
+++ /dev/null
@@ -1,36 +0,0 @@
-PACKAGE_ARCH = "all"
-
-do_configure() {
- :
-}
-
-do_compile() {
- :
-}
-
-pkg_postinst_fonts() {
-#!/bin/sh
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postrm_fonts() {
-#!/bin/sh
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir -f
-}
-
-python populate_packages_prepend() {
- postinst = bb.data.getVar('pkg_postinst_fonts', d, 1)
- postrm = bb.data.getVar('pkg_postrm_fonts', d, 1)
- fontdir = bb.data.getVar('palmtopdir', d, 1) + '/lib/fonts'
- pkgregex = "^([a-z-]*_[0-9]*).*.qpf$"
- pkgpattern = bb.data.getVar('QPF_PKGPATTERN', d, 1) or 'qpf-%s'
- pkgdescription = bb.data.getVar('QPF_DESCRIPTION', d, 1) or 'QPF font %s'
-
- do_split_packages(d, root=fontdir, file_regex=pkgregex, output_pattern=pkgpattern,
- description=pkgdescription, postinst=postinst, postrm=postrm, recursive=True, hook=None,
- extra_depends='qpf-font-common')
-}
diff --git a/meta/classes/qt3e.bbclass b/meta/classes/qt3e.bbclass
deleted file mode 100644
index c34d7c04f5..0000000000
--- a/meta/classes/qt3e.bbclass
+++ /dev/null
@@ -1,11 +0,0 @@
-#
-# override variables set by qmake-base to compile Qt/X11 apps
-#
-export QTDIR="${STAGING_DIR}/${HOST_SYS}/qte3"
-export QTEDIR="${STAGING_DIR}/${HOST_SYS}/qte3"
-export OE_QMAKE_UIC="${STAGING_BINDIR}/uic3"
-export OE_QMAKE_MOC="${STAGING_BINDIR}/moc3"
-export OE_QMAKE_CXXFLAGS="${CXXFLAGS} "
-export OE_QMAKE_INCDIR_QT="${QTEDIR}/include"
-export OE_QMAKE_LIBDIR_QT="${QTEDIR}/lib"
-export OE_QMAKE_LIBS_QT="qte"
diff --git a/meta/classes/qt3x11.bbclass b/meta/classes/qt3x11.bbclass
deleted file mode 100644
index 6e3d5f8ba2..0000000000
--- a/meta/classes/qt3x11.bbclass
+++ /dev/null
@@ -1,15 +0,0 @@
-DEPENDS_prepend = "${@["qt3x11 ", ""][(bb.data.getVar('PN', d, 1) == 'qt-x11-free')]}"
-EXTRA_QMAKEVARS_POST += "CONFIG+=thread"
-#
-# override variables set by qmake-base to compile Qt/X11 apps
-#
-export QTDIR = "${STAGING_DIR}/${HOST_SYS}/qt3"
-export OE_QMAKE_UIC = "${STAGING_BINDIR}/uic3"
-export OE_QMAKE_MOC = "${STAGING_BINDIR}/moc3"
-export OE_QMAKE_CXXFLAGS = "${CXXFLAGS} -DQT_NO_XIM"
-export OE_QMAKE_INCDIR_QT = "${QTDIR}/include"
-export OE_QMAKE_LIBDIR_QT = "${QTDIR}/lib"
-export OE_QMAKE_LIBS_QT = "qt"
-export OE_QMAKE_LIBS_X11 = "-lXext -lX11 -lm"
-
-
diff --git a/meta/classes/qt4x11.bbclass b/meta/classes/qt4x11.bbclass
deleted file mode 100644
index 635fc67694..0000000000
--- a/meta/classes/qt4x11.bbclass
+++ /dev/null
@@ -1,17 +0,0 @@
-DEPENDS_prepend = "qmake2-native "
-DEPENDS_prepend = "${@["qt4x11 ", ""][(bb.data.getVar('PN', d, 1) == 'qt4-x11-free')]}"
-#
-# override variables set by qmake-base to compile Qt4/X11 apps
-#
-export QTDIR = "${STAGING_DIR}/${HOST_SYS}/qt4"
-export QMAKESPEC = "${QTDIR}/mkspecs/${TARGET_OS}-oe-g++"
-export OE_QMAKE_UIC = "${STAGING_BINDIR}/uic4"
-export OE_QMAKE_MOC = "${STAGING_BINDIR}/moc4"
-export OE_QMAKE_RCC = "${STAGING_BINDIR}/rcc4"
-export OE_QMAKE_QMAKE = "${STAGING_BINDIR}/qmake2"
-export OE_QMAKE_LINK = "${CXX}"
-export OE_QMAKE_CXXFLAGS = "${CXXFLAGS}"
-export OE_QMAKE_INCDIR_QT = "${QTDIR}/include"
-export OE_QMAKE_LIBDIR_QT = "${QTDIR}/lib"
-export OE_QMAKE_LIBS_QT = "qt"
-export OE_QMAKE_LIBS_X11 = "-lXext -lX11 -lm"
diff --git a/meta/classes/wrt-image.bbclass b/meta/classes/wrt-image.bbclass
deleted file mode 100644
index ba1163a719..0000000000
--- a/meta/classes/wrt-image.bbclass
+++ /dev/null
@@ -1,33 +0,0 @@
-# we dont need the kernel in the image
-ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/zImage*"
-
-def wrt_get_kernel_version(d):
- import bb
- if bb.data.inherits_class('image_ipk', d):
- skd = bb.data.getVar('STAGING_KERNEL_DIR', d, 1)
- return base_read_file(skd+'/kernel-abiversion')
- return "-no kernel version for available-"
-
-wrt_create_images() {
- I=${DEPLOY_DIR}/images
- KERNEL_VERSION="${@wrt_get_kernel_version(d)}"
-
- for type in ${IMAGE_FSTYPES}; do
- # generic
- trx -o ${I}/wrt-generic-${type}.trx ${I}/loader.gz \
- ${I}/wrt-kernel-${KERNEL_VERSION}.lzma -a 0x10000 ${I}/${IMAGE_NAME}.rootfs.${type}
-
- # WRT54GS
- addpattern -2 -i ${I}/wrt-generic-${type}.trx -o ${I}/wrt54gs-${type}.trx -g
-
- # WRT54G
- sed "1s,^W54S,W54G," ${I}/wrt54gs-${type}.trx > ${I}/wrt54g-${type}.trx
-
- # motorola
- motorola-bin ${I}/wrt-generic-${type}.trx ${I}/motorola-${type}.bin
- done;
-}
-
-IMAGE_POSTPROCESS_COMMAND += "wrt_create_images;"
-
-DEPENDS_prepend = "${@["wrt-imagetools-native ", ""][(bb.data.getVar('PACKAGES', d, 1) == '')]}" \ No newline at end of file