aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/package_ipk.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-01 14:18:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-01 16:50:59 +0000
commitea11f71432e2741d5f8c7cecec41c6155db34393 (patch)
tree3b5622767aab4c8efc820f5192dc08303856d228 /meta/classes/package_ipk.bbclass
parentc367a2d2f4b817211b6bd200e49b49355cd67fe2 (diff)
downloadopenembedded-core-ea11f71432e2741d5f8c7cecec41c6155db34393.tar.gz
package_ipk: There is no longer any need to force owners/groups to root
Since the packaging process is run under pseudo, the default user is now root so there is no longer any need to hardcode this. Also take this opportunity to move the variable to package_ipk.bbclass since this is the only user of it. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package_ipk.bbclass')
-rw-r--r--meta/classes/package_ipk.bbclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index c0893a6cda..c97e36eeb2 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -7,6 +7,9 @@ IPKGCONF_SDK = "${WORKDIR}/opkg-sdk.conf"
PKGWRITEDIRIPK = "${WORKDIR}/deploy-ipks"
+# Program to be used to build opkg packages
+OPKGBUILDCMD ??= "opkg-build"
+
python package_ipk_fn () {
bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
}