summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/fortran
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-30 14:23:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-02 15:15:26 +0100
commitd73595df69667fe9d12ecd407b77a0b8dae2109c (patch)
treef2159803af37b2272f01704d0850ad1f6d8e2add /meta-selftest/recipes-test/fortran
parentf25dd633fffe6560f191526d1869e657e129bad9 (diff)
downloadopenembedded-core-d73595df69667fe9d12ecd407b77a0b8dae2109c.tar.gz
recipes: Update WORKDIR references to UNPACKDIR
Since we want to be able to stop unpacking to WORKDIR, correct the WORKDIR references in recipe do_compile/do_install tasks to use UNPACKDIR in the appropraite places instead. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test/fortran')
-rw-r--r--meta-selftest/recipes-test/fortran/fortran-helloworld.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
index 3a46404477..a897966608 100644
--- a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
+++ b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
@@ -11,7 +11,7 @@ SECURITY_CFLAGS = ""
SECURITY_LDFLAGS = ""
do_compile() {
- ${FC} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello
+ ${FC} ${LDFLAGS} ${UNPACKDIR}/hello.f95 -o ${B}/fortran-hello
}
do_install() {