summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-05 10:15:24 +0000
committerRoss Burton <ross@openedhand.com>2007-11-05 10:15:24 +0000
commit94b124a62e89e470d3b628307622a492437525fe (patch)
tree2447ea6c3ade08378b91acea26145044ebebf2c7 /meta-extras
parente51fbab510c1a2228b61bfa9dd13e6b964cdc721 (diff)
downloadopenembedded-core-94b124a62e89e470d3b628307622a492437525fe.tar.gz
Add ubootchart
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3065 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/ubootchart/files/sysvinit.patch12
-rw-r--r--meta-extras/packages/ubootchart/ubootchart_svn.bb22
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-extras/packages/ubootchart/files/sysvinit.patch b/meta-extras/packages/ubootchart/files/sysvinit.patch
new file mode 100644
index 0000000000..de9fb0b17d
--- /dev/null
+++ b/meta-extras/packages/ubootchart/files/sysvinit.patch
@@ -0,0 +1,12 @@
+Index: ubootchart.conf
+===================================================================
+--- ubootchart.conf (revision 9)
++++ ubootchart.conf (working copy)
+@@ -1,6 +1,6 @@
+
+ # If you want to chain on and run somthing other than /sbin/init...
+-export init_prog=/sbin/init
++export init_prog=/sbin/init.sysvinit
+
+ # On startup ubootchart will mount a tmpfs filesystem at this
+ # location and chdir here. This is only used for the logging of
diff --git a/meta-extras/packages/ubootchart/ubootchart_svn.bb b/meta-extras/packages/ubootchart/ubootchart_svn.bb
new file mode 100644
index 0000000000..b3f1ad30ee
--- /dev/null
+++ b/meta-extras/packages/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A boot profiling tool"
+HOMEPAGE = "http://code.google.com/p/ubootchart/"
+LICENSE="GPLv3"
+
+SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
+ file://sysvinit.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/trunk"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
+}
+
+do_install() {
+ install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart
+ install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
+ install -m 0755 ${S}/ubootchartd ${D}/sbin
+ install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
+ install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
+ install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
+}
+