summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-09-25 15:52:21 +0000
committerRoss Burton <ross@openedhand.com>2007-09-25 15:52:21 +0000
commit2c13e1b5b5fd442c3d0baa3391a49054df03392d (patch)
tree8a4bcb22c698e78875dea108d3e51e26802f32e8 /meta-extras
parent3cc1591ead410cb4a5f4d3600546361d3432f99d (diff)
downloadopenembedded-core-2c13e1b5b5fd442c3d0baa3391a49054df03392d.tar.gz
Remove dhcdbd, NM 0.7 doesn't need it
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2790 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/dhcdbd/dhcdbd_2.0.bb25
-rw-r--r--meta-extras/packages/dhcdbd/files/dbus-api-fix.patch20
-rw-r--r--meta-extras/packages/dhcdbd/files/dhcdbd28
-rw-r--r--meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch26
-rw-r--r--meta-extras/packages/dhcdbd/files/no-ext-options.patch13
5 files changed, 0 insertions, 112 deletions
diff --git a/meta-extras/packages/dhcdbd/dhcdbd_2.0.bb b/meta-extras/packages/dhcdbd/dhcdbd_2.0.bb
deleted file mode 100644
index de9e24abd5..0000000000
--- a/meta-extras/packages/dhcdbd/dhcdbd_2.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION="DBus-enabled dhcp client"
-SECTION="net"
-LICENSE="GPL"
-HOMEPAGE="http://people.redhat.com/jvdias/dhcdbd/"
-
-DEPENDS = "dbus"
-RDEPENDS = "dhcp-client"
-
-PR = "r0"
-
-SRC_URI="http://people.redhat.com/dcantrel/dhcdbd/dhcdbd-${PV}.tar.bz2 \
- file://no-ext-options.patch;patch=1 \
- file://dhcdbd"
-
-do_compile() {
- CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
-}
-
-do_install() {
- DESTDIR=${D} make install
- install -d ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
-}
-
-FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"
diff --git a/meta-extras/packages/dhcdbd/files/dbus-api-fix.patch b/meta-extras/packages/dhcdbd/files/dbus-api-fix.patch
deleted file mode 100644
index ce05fc7bf8..0000000000
--- a/meta-extras/packages/dhcdbd/files/dbus-api-fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- /tmp/dbus_service.c 2006-08-24 22:09:14.000000000 +0200
-+++ dhcdbd-1.14/dbus_service.c 2006-08-24 22:09:44.228306000 +0200
-@@ -1412,7 +1412,7 @@
- return ( cs );
-
- give_up:
-- dbus_connection_disconnect( connection );
-+ dbus_connection_close( connection );
- dbus_shutdown();
- return ( 0L );
- }
-@@ -1456,7 +1456,7 @@
- cs->roots=0L;
-
-
-- dbus_connection_disconnect( cs->connection );
-+ dbus_connection_close( cs->connection );
- dbus_shutdown();
- free( cs );
- }
diff --git a/meta-extras/packages/dhcdbd/files/dhcdbd b/meta-extras/packages/dhcdbd/files/dhcdbd
deleted file mode 100644
index 568753c28c..0000000000
--- a/meta-extras/packages/dhcdbd/files/dhcdbd
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# DHCDBD startup script
-
-. /etc/profile
-
-case $1 in
- 'start')
- echo -n "Starting dhcdbd daemon: dhcdbd"
- /sbin/dhcdbd --system
- echo "."
- ;;
-
- 'stop')
- echo -n "Stopping dhcdbd: dhcdbd"
- killall `ps |grep /sbin/dhcdbd | grep -v grep | cut "-d " -f2`
- echo "."
- ;;
-
- 'restart')
- $0 stop
- $0 start
- ;;
-
- *)
- echo "Usage: $0 { start | stop | restart }"
- ;;
-esac
diff --git a/meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch b/meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
deleted file mode 100644
index c2e2151d17..0000000000
--- a/meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -Naur dhcdbd-1.14/Makefile dhcdbd-1.14-mod/Makefile
---- dhcdbd-1.14/Makefile 2006-01-17 22:23:51.000000000 +0100
-+++ dhcdbd-1.14-mod/Makefile 2006-08-02 18:02:42.000000000 +0200
-@@ -7,8 +7,8 @@
- LDFLAGS ?= -g
- DESTDIR ?= /
- LIBDIR ?= lib
--DBUS_INCLUDES ?= -I/usr/$(LIBDIR)/dbus-1.0/include -I/usr/include/dbus-1.0
--DBUS_LIBS ?= -ldbus-1
-+DBUS_INCLUDES ?= `pkg-config dbus-1 --cflags`
-+DBUS_LIBS ?= `pkg-config dbus-1 --libs`
- OBJS = dbus_service.o dhcdbd.o dhcp_options.o main.o
- SRCS = dbus_service.c dhcdbd.c dhcp_options.c main.c
- INCS = dbus_service.h dhcdbd.h dhcp_options.h includes.h
-diff -Naur dhcdbd-1.14/tests/Makefile dhcdbd-1.14-mod/tests/Makefile
---- dhcdbd-1.14/tests/Makefile 2006-01-17 22:23:51.000000000 +0100
-+++ dhcdbd-1.14-mod/tests/Makefile 2006-08-02 18:11:43.000000000 +0200
-@@ -2,7 +2,7 @@
- LD = ${CC}
- CFLAGS ?= -g -Wall
- LDFLAGS ?= -g
--DBUS_LIBS ?= -ldbus-1
-+DBUS_LIBS ?= `pkg-config dbus-1 --libs`
-
- all: test_dhcp_options test_dhcdbd_state test_subscriber test_subscriber_dbus test_prospective_subscriber
-
diff --git a/meta-extras/packages/dhcdbd/files/no-ext-options.patch b/meta-extras/packages/dhcdbd/files/no-ext-options.patch
deleted file mode 100644
index 774a2cf140..0000000000
--- a/meta-extras/packages/dhcdbd/files/no-ext-options.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: dhcdbd-2.0/include/dhcdbd.h
-===================================================================
---- dhcdbd-2.0.orig/include/dhcdbd.h 2006-10-18 09:38:18.000000000 +0100
-+++ dhcdbd-2.0/include/dhcdbd.h 2006-10-18 09:38:45.000000000 +0100
-@@ -76,7 +76,7 @@
- #endif
-
- #ifndef DHCLIENT_EXTENDED_OPTION_ENVIRONMENT
--#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 1
-+#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 0
- #endif
-
- #define DHCDBD_INTERFACE_TEXT "text"